Date format in Generated Documents

Options
Rytis Karalius
edited 02/07/22 in Smartsheet Basics

Hi everyone

I am trying to fill document with various fields.

Date field is causing problems, because it cannot be formatted in any way.

The output is only like this: yy.mm.dd, whereas i need yyyy.mm.dd

I've tried cell formatting and PDF formatting - nothing helps.


If you map date to PDF - it shows date as a regional format for a chosen region in Smartsheet i believe, which is totally wrong for Lithuania.



So there are few questions:

  1. How do i set proper date formatting for my documents because it is really important?
  2. How do i get regional date format changed to what it has to look like?


Answers

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Rytis Karalius

    At this time, Document Builder formats dates based on your Personal Settings date format:

    If you need a different date format to be generated, I would suggest choosing a different Regional Preference that has the correct format that you'd like. For example, I South Africa should have YYYY/MM/DD

    Please let the Product team know about your use-case and feature request by filling in this form, here!

    Thank you,

    Genevieve