Cannot create new mappings in Document Builder


For some reason, I can no longer create a new mapping in Document Builder. I can create mappings in other Smartsheet accounts that I manage for other companies, but not the main Smartsheet account for my company.

When I click on "Create a new Mapping," I get taken to the correct screen, but the Create a Document Mapping button is grayed out.

The mapping I created prior to the emergence of this issue is still there, but is invalid. I tried revoking the app integration, but now I can't re-attach the app.

This has been going on for three days without a whisper of support from Smartsheet, and I have deadlines looming. Can anybody here assist?

Background: I am the account owner, sheet owner, and a licensed user, so permissions aren't an issue. The trigger for the workflow is a simple row addition. Also, the workflow has worked correctly in the past. Furthermore, document mappings work just fine in other Smartsheet accounts that I manage for clients.