When Power Automate inserts data in Smartsheet, how to work correctly with formatted columns?


I have a Microsoft Form that my sales team fills out when they win an order. I have created a Power Automate flow to create a new line in Smartsheet and insert this data. I am using MS Forms + Power Automate and not Smartsheet's form because it also performs other actions outside Smartsheet.

However, on the columns that are "Sale Value" and "GP %", they are formatted as dollar value and percentage, see below. Power Automate inserts the data in these columns as a string and I have to remove an apostrophe to display correctly.

Is there a way to have Power Automate insert this data correctly?



  • ro.fei
    ro.fei ✭✭✭✭✭

    I would try using "Format data by examples" within Power Automate to eliminate the ' & see if that works. Let me know if it works, if not I'll help you brainstorm another workaround!

  • Brant F.

    Ok, I just tried Format data by examples, but it didn't work. Do you have a particular example that works?

    I have tried a few but it still inputs the data in Smartsheet as a string with a ' at the beginning.

    These were all inserted as strings.