Sign in to submit new ideas and vote
Get Started

Clear buffer on a form after use

Options

Avoid the form from saving your information when clicking a field.

Tags:
2
2 votes

Idea Submitted · Last Updated

Comments

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Thom in Ottawa

    Can you explain a little further? It would be helpful to see screen capture examples or a story / use-case that's associated with this request.

    Thanks!

    Genevieve

  • Thom in Ottawa
    Options

    Hey, I hope this helps!


    Thom

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hey @Thom in Ottawa

    Thanks so much! This looks to be a Browser setting where auto-fill is turned on. You can disable this in your browser and clear the Cache for this specific URL (the form) to get rid of the suggestions.

  • Thom in Ottawa
    Options

    Yes, it can be, but each user may not do it, which is a problem.

    I am hoping it can be controlled from the form settings. (so the builder of the form sets it)

  • Thom in Ottawa
    Options

    I am unsure if you are AI or just not reading what I sent you. I sent you a PIC wit exactly what the issue is. Pleas look at it.

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Thom in Ottawa

    I'm also Canadian! But I live and work in the UK so my timezone is a little different than yours. 🙂

    There currently isn't a way to control browser auto-fill or suggestion settings from directly within Smartsheet's form settings. Thanks for posting your Idea!

    To clarify, this will be specific to your browser... meaning that if I went to fill out your form from my computer here in England, I wouldn't see those suggestions. They're only showing because you have entered them before from that browser and device. Does that make sense?

    Cheers,

    Genevieve

  • Thom in Ottawa
    Options

    Hello, fellow Canadian!

    Yes, it does. I do understand the individuality of the form.

    An example of the issue this causes is this. We gather client information on a form. Name, address and credit card information. Once it is sent, we do not want the employee to be able to see it again. Of course, what is happening is they can, which is not great from a security standpoint.

    I totally understand the browser part of this. I was just hoping that clearing out the buffer could be controlled from the form itself.

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Thanks for clarifying your use-case.

    Since this isn't currently something Smartsheet can adjust, I would recommend asking all of your employees to use the same browser and ensure auto-fill is turned off.

    Personally, I'm using Chrome, so this is the setting area ("Addresses and more") that removes the suggestions and ensures the previous data is not saved:


    I hope that helps!

    Cheers,

    Genevieve

  • Glanso UK
    Options

    Hi,

    We have been suffering with exactly the same problem. We have 200 different staff filling in Forms once a month. Autofill is causing big problems as it changes data entered higher up in the form. I cannot ask all the staff to disable the function on their browsers.

  • Glanso UK
    Options

    On Forms: in a similar way you have the option to make the question mandatory or not, there should be an option to 'not allow autofill'. The browser autofill function populates many boxes and results in data and dates being changed as forms are being filled. This is causing my company huge problems