Control center behaves different with primary and additional lead logins

Options

Hi,

I am building a Control Center solution. I have just created 4 projects, so I can just delete the projects and start over again. However, the problems that I am facing are real-life problems. Therefore I want to solve them, so if I am handling 500 projects, I don't ever think about re-creating 500!

My Control Center program has only one blueprint with one primary lead (service account) and one additional lead (my account). I have the credentials for both the leads so I can look at the project from both logins; both in Control Center and in Smartsheet.

The problem started when after rolling out 4 projects I realised that I had missed out a report on the dashboard, so I added the dashboard via Global Update > Update Dashboards. I logged into Control Center using my account and when I ran the "Update Dashboard", I was surprised to see that Control Center was saying "Choose Dashboard", instead of showing the dashboard's actual name. In this case I had to click on this link and add the dashboard. Please see the two screenshots.


After rolling out the dashboard (like above), instead of my dashboard being updated with the additional report, I ended up with two dashboards with the same name. The old dashboard is owned by the service account and the new one is owned by me!

So my first question is "why did I end up with two dashboards" ? How to fix this? The intake sheet and the summary sheet point to the old dashboards. Why?

In trying different things, I deleted both dashboards for PRJ-00006.

Next, I decided to login through the service account and try and achieve the same (update dashboard) through there. To my surprise, the Control Center analyses the dashboards differently through the service account and through my account. Why is that so?

The above view is when I run Update Dashboard through my account. I have crossed out my name.


The above view is when I run Update Dashboard through the service account. I have crossed out my name. See how it is showing the dashboard names correctly?


Now when I run Update Dashboard through my account, it creates a new dashboard. When I run Update Dashboard through the service account, the "apply test" passes but gives an error at the same time.

The above screenshot when I apply test to any project through the service account.


Any help would be appreciated. Could the gurus comment please?


Regards,

AK

Answers