Data Shuttle error on export to Excel

I'm receiving this error and cannot figure out why:

"The workflow has been executed with an error. Workflow Execute: Could not access target. Please check your workflow configuration for errors."


I've relogged into SharePoint several times, selected the correct folder, ensured the excel file is closed, etc. Still getting the error though. This particular data shuttle worked fine until I went to make a small change to the number of fields synced. Now it won't work at all.

I'm curious if this is a known issue? Happy to file a ticket either way.

Answers

  • Ric T
    Ric T ✭✭✭✭✭

    Hi @johngraham78,

    Just wanted to double check that "Source Location" is selected as "OneDrive & Sharepoint", and after signing in through the external account (a login window would prompt up if you're not already signed in), you clicked on the magnifying glass icon to search for the file name?

    Can you check whether after selecting the file name, the file name ends with the extension ".csv", or ".xlsx"? If no, try renaming your file in your SharePoint to add the extension, then retry and select the source file again.

    Cheers,

    Ric

  • @Ric T , thanks for the question. Yes, I have confirmed all of those.

    I reached out to support and they confirmed this is a known issue. I'll post on this thread once they have a solution.

  • Archiduc
    Archiduc ✭✭✭

    I have the same issue I guess I will open a ticket as well, thanks for sharing.

  • johngraham78
    johngraham78 ✭✭✭
    edited 01/26/24

    @Archiduc Yes, file a ticket. I did and the problem was resolved rather quickly. It appears their fix was not universal though, and/or another issue came up.

    Regardless, here was their response from a few weeks ago:


    Thanks for contacting Smartsheet Support. I understand that you're having issues with your Data Shuttle workflow which was failing and you’re receiving an error even after you’ve logged into Sharepoint. I'd be glad to advise further. 

     The behavior you're currently seeing with your workflow is reported as a known issue by our Engineering team. We're currently working on a fix to this matter and while we cannot provide a specific ETA when this issue will be resolved, please be assured that our Engineering team is actively investigating this and communicating with Microsoft to deploy a fix as soon as possible. 

    For the meantime, I have recorded your report of the issue and please wait until our Engineering team has an update to this matter. Also, the case might be tagged as Resolved despite the issue re-occurring but keep in mind that we have documented your case as affected by the current issue. Please understand and we greatly appreciate your continuous cooperation while we work on this. 

    Thanks for using Smartsheet! If there are no additional questions on this topic or your issue has been resolved, there is no need to reply to this email.

  • Archiduc
    Archiduc ✭✭✭

    Thanks, it seems we did not have the same issue after all, as mine was not working beforehand, it just never worked when I tried it for the first time.

    Support mentioned I must ask my IT to let Smartsheet write on our Sharepoint. I hadn't found that on any documentation, which is a bit annoying.

    They gave me the app client id and the Required Permissions:

    offline_access files.readwrite

    sites.readwrite.all user.read