AppSheet and SmartSheet

TJC
TJC
edited 02/09/24 in Add Ons and Integrations

Hello, I set up an AppSheet Mobile app to feed into a sheet. It looks like there is some data matching issue, as the data appears to come in as text.

In AppSheet the data is set up as Percent with Max Min and Interval levels of 100, 0 and 50. This gives me three options, 0%, 50% & 100%.

In my sheet the column is set up as Drop Down List with restricted values of 0%, 50% and 100%.

The data seems to transfer fine from AppSheet but it is left justified and is making my formulas give errors, which makes me think it is coming over as text.

I've tried different Data Types in both AppSheet and Smartsheet with no luck.

I've used a similar setup on another sheet and it worked fine. Anyone have any ideas?

Answers

  • Bassam Khalil
    Bassam Khalil ✭✭✭✭✭✭

    Hi @TJC,

    The problem seems to stem from the way numeric data formatted as percentages in AppSheet is being interpreted as text when it's transferred to Smartsheet, despite the correct setup in both applications. Here are a few steps and tips that might help resolve this issue:

    1. Verify Data Formats in AppSheet

    • Ensure that the data type for your percent fields in AppSheet is indeed set to "Percent" and check if there are any additional settings that might affect the data output, such as text formatting options that could override the numeric nature of your data.

    2. Check Smartsheet Column Configuration

    • Double-check that the column in Smartsheet where you're importing this data is correctly set up to accept percentages. Even though you've set it up as a Drop Down List with specific percentage values, ensure that the column type is compatible with numeric data and not just plain text.

    3. Use a Data Cleanup Formula in Smartsheet

    • If the data continues to be imported as text, you might consider using a helper column in Smartsheet to convert text to the appropriate numeric percentage value. For example, you could use a formula like VALUE(SUBSTITUTE([Column Name]@row, "%", "")) / 100 to convert a text string like "50%" into a numeric 0.5, which Smartsheet can then recognize as 50%.

    4. Re-Examine Integration Settings

    • Review the integration or automation rules you've set up between AppSheet and Smartsheet. Ensure there's nothing in the integration logic that might inadvertently convert numeric data to text during the transfer process.

    5. Test with a Simple Setup

    • Try creating a new, simple AppSheet form and a new Smartsheet with just the necessary columns for testing. See if the issue persists with this simplified setup. This can help isolate whether the problem is with the specific configuration of your original sheet or a more general issue with the data transfer.

    6. Contact Support

    • If you've tried these steps and are still facing issues, consider reaching out to Smartsheet and AppSheet support. Provide them with detailed information about your setup and the issue. Sometimes, platform-specific quirks or bugs may be at play, and their support teams can offer more direct assistance or workarounds.


    PMP Certified

    [email protected]

    ☑️ Are you satisfied with my answer to your question? Please help the Community by marking it as an ( Accepted Answer), and I will be grateful for your "Vote Up" or "Insightful"

  • CASTRO
    CASTRO ✭✭

    I have the same problem, It seems a recent issue since it works fine until recently.

  • Thank you Bassam,


    I've done all of the above except the data cleanup formula. The number of columns I have makes this impractical.


    I will try contacting Customer Support.


    Thanks!