Missing Person (Icon)

Options

Hi there,

In the past, when I needed to share a sheet with a new employee, I would click the person icon in the box below "invite people and groups" from the "share" view (see red circle below) and then "add new" when the next screen appeared, but the person icon is no longer in that box. I found a workaround by going to My Account -->My Smartsheet Contacts -->Add ... but it is not as clean as the other method. Am I the only one experiencing the person icon missing?


Answers

  • Itai
    Itai ✭✭✭✭✭✭
    Options

    Hi @Laura K Wallace

    Great point, have you considred starting to write the person/group name so you can get the dropdown with the options? At least until they bring it back hopefully.

    Itai Perez

    Project Manager | Transformation Department

    Gong cha

    If you found my comment helpful any reaction, Insightful, Awsome etc... would be appreciated🙂

    https://www.linkedin.com/in/itai-perez-740543116/

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @Laura K Wallace

    The sharing window was redesigned last month for clarity and speed; the removal of the person icon was an intentional design update. You can still achieve the same thing by entering the new email into the “invite people and groups” input field.

    • Type in the email - you'll see "Add XXX" in the dropdown
    • Once added, the new email populates in the field
    • Anytime you search for that email in the future, it will automatically appear in the search dropdown

    You can of course go to "My Smartsheet Contacts" in your menu as you found, as well. 🙂

    Cheers,

    Genevieve

  • Laura K Wallace
    Options

    Hi Itai, and thank you for the suggestion! I did try that and could add the person that way, but it only shows their email in the distribution list instead of their name and then their email address under their name. But it is definitely a workaround that will work, so I really appreciate your time!