Smartsheet for Google Docs is no longer working


This error started to appear. I've already installed and uninstalled it and it doesn't help, it's still the same thing.

There was also an error on another account I have, but in this case it was related to token authorization.

Is anyone having problems with this extension too? It is very important to us!


  • MWilkesen
    MWilkesen ✭✭✭

    I had a similar issue recently, and the issue was my Google permissions had to be updated.

  • paulen
    paulen ✭✭✭

    Hi @MWilkesen Thanks for your answer but it didn't solve my problem. I've already gone through the permission process several times because I installed and uninstalled this extension several times to try to fix it.

  • MWilkesen
    MWilkesen ✭✭✭

    Oh man, I am sorry about that!

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @paulen

    Please try these steps to disconnect/re-add the Merge integration:

    1. In Smartsheet, revoke the Smartsheet Google Doc Merge integration under Apps & Integrations:
    2. Sign out of Smartsheet
    3. In Google, remove/uninstall the Smartsheet for Google Docs add-on in a Google Doc:
      1. Go to Extensions->Add-ons->Manage add-ons
      2. Uninstall the Smartsheet for Google Docs add-on via the Options menu (3 dots)
    4. Sign out of Google account and then sign back into Google account
    5. Open a Google Doc and re-add the Smartsheet for Google Docs add-on
      1. Go To Extensions->Add-ons->Get add-ons
      2. Find the Smartsheet for Google Docs add-on and Install it
    6. Once it’s installed, enable the add-on by going to Extensions->Smartsheet for Google Docs-> Start
    7. The add-on will appear in the Google Doc on the right. Click Connect to Smartsheet and proceed with enabling it

    If this doesn't help, please contact Smartsheet Support with a screen recording of what you're seeing explaining that you have tried the steps above.

    Thank you,