In trigger the option of Daily or Hourly is not working for me ?

edited 05/21/24 in Smartsheet Basics

I have 5 sheet distributed o five employee asking them to update sheet each month. All the entries will automatically saved to one master file which is my database for analysis. But each Control + S by an employee is creating another record in my master database, Currently the workflow is set to run when triggered but I want it set it to trigger only once in a day, but that option is not seems to working. The purpose is to avoid duplication of data.