Filter default settings

Jean Black
Jean Black ✭✭✭
edited 12/09/19 in Smartsheet Basics

I use up to 5 sheets at any one time, each containing information relating to different customers.  I frequently need to filter information on any particular sub-client via a text/number column.  The default ‘Create New Filter’ uses  “contains” for me to enter a unique name of the sub-client, and all rows applicable to that sub-client becomes visible.  

We have recently created the 5th sheet by “Save as New” and re-naming, then clearing all old data.  This new sheet contains only one customer but has many sub-clients.  The description in the same text/number column is very repetitive, with sub-client identification being, say HLD SA009 or LPV UN005, or similar.  When I now try to filter any one sub-client in this 5th sheet, the default comes up as “is one of”, and not “contains”.

Can someone explain why this new sheet which should have all the original formatting now has changed the default filter settings.  Alternatively, can someone explain how we can change/re-set this incorrect default filter.


  • Shaine Greenwood

    Hi Jean,

    I'm not sure if this is expected behavior or not. I'd recommend reaching out to our Support team directly to troubleshoot the behavior with them. They may need to get shared on your sheets, or see a screenshare/video of your sheet with the "contains" filter on it, then you saving as new to find that filter change to "is one of"=>'

  • Jean Black

    Thank you Shaine for your suggestion.  As it happens, I was trying to work out why (there seemed no logical reason) why one sheet should be different from all the others.  I finally used a process of elimination and found that there was a need for a minimum amount of information to trigger the "contains" choice.  Up until then, there were few enough variables to allow the "is one of" to work.  I have since added some rows of sub-clients, and the problem is solved.  I knew there had to be a logical reason for the problem - it was just a case of catching up with Smartsheet....  Thanks again.  Jean