Welcome to the Smartsheet Forum Archives

The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Cannot open published calendar in Outlook

Nick Osborne
edited 12/09/19 in Archived 2016 Posts

I am trying to publish and open a calendar in Outlook but receiving an error. I have tried clicking the link to the calendar directly in SmartSheet (Go to Calendar View on the left menu, then select Publish at the bottom, enable publishing and Get Link). And I have tried going into Outlook and adding ti manually via File, Account Settings, Internet Calendars and adding it here. When I do the first option, it pops a window very briefly then it disappears and nothing else happens. When I do the second way, I get the error below:

Task 'Internet Calendar Subscriptions' reported error (0xF5904005) : 'Cannot verify or add the calendar to Outlook. Make sure the following link is a valid calendar link:
http://publish.smartsheet.com/*calendar address*.ics'

I did notice that Outlook is changing it from webcal:// to http://.


Anyone have any ideas?


  • Shaine Greenwood
    Shaine Greenwood Employee
    edited 10/27/16

    Hi Nick—I've heard of this issue occurring before and you're on the right track that it's due to Outlook changing the identifier at the beginning of the link from webcal:// to http://


    Your next step is to contact Support@Smartsheet.com as I believe they have a potential workaround for this issue.

  • James Framke

    Ran into this problem as well. Not applicable to all users, but as a workaround Office 365 allows the .ics link to be added to the online calendar interface, which will then sync to the desktop client.

  • R.Silber
    R.Silber ✭✭✭✭

    I'm having this same problem since moving to Windows 10 (business) and Office 2016 (enterprise). I have emailed support and they said -- months ago -- that it's a known issue with Microsoft and that Smartsheet is working on it. But I have yet to hear about a solution or work-around. It's very frustrating and I really need this valuable feature back.

  • R.Silber
    R.Silber ✭✭✭✭

    I'm still having this problem, and am continuing to feel frustrated about it. I notice now that the link to copy at least begins again with "webcal://..." like it used to and is supposed to. But it still doesn't work. And when I try to just download the .ics file, it doesn't seem to download anywhere on my system. Anyone have any hints for me?

This discussion has been closed.