Copy Row Issue

Options
L_123
L_123 ✭✭✭✭✭✭

Just had an issue where my copy to workflow only worked on 2 rows out of ~15. This is not a new workflow, and has been tested and functional over 30 times, and no one has accessed or changed anything in the sheet other than me.

Is anyone else having any issues with this? I really need the workflow to be trustworthy for this purpose, I am using it to collect end of shift data and can't afford to lose it.

Answers

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭
    Options

    I haven't had any issues, but then again my copy/move row automations are more for archiving purposes.


    I assume you've double checked the rows that were missed and made sure that they should have definitely triggered the automation?

  • Genevieve P.
    Options

    Hmm, that does sound strange. What is causing the trigger for the automation?

    I would recommend reaching out to Support if you haven't already.

    Join us at Smartsheet ENGAGE 2024 🎉
    October 8 - 10, Seattle, WA | Register now

  • L_123
    L_123 ✭✭✭✭✭✭
    Options

    @Paul Newcome Yes, It stands out like a sore thumb when there are errors because there is a regular submission frequency of twice every day. I deleted the submissions that messed up, and resubmitted the information fine. It wasn't a problem to fix. It's just that when this is running I don't want to have to worry about double checking to make sure the program that should have functioned did every day.

    @Genevieve P a column with a checkbox in the first row, and if statements in each following row referencing the first one and posting a comma if checked and a period if not. There is a workflow with different options to send to different sheets depending on criteria activated when any value changes in the checkbox row.

    It seems to be working again, but I am worried about my information being reliable in the future. On further review i've already lost a decent amount of historical data on smartsheet posting a 0 instead of the actual value in calculated cells on the same sheet, even though the formula is working. I wonder if the transfer isn't letting the formulas finish calculating before sending to the other sheet.

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭
    Options

    @L@123

    " I wonder if the transfer isn't letting the formulas finish calculating before sending to the other sheet."


    I have often wondered the same thing and have come across reason to believe this is true a number of times. If I remember correctly, I believe there was someone else that posted in the community about a similar issue with form submissions with autofill formulas not always being fully pulled.


    I wonder what would happen if you moved the trigger column to the far right of the sheet of if you include in the criteria that generates your trigger that all of the rest of the columns are not blank before it generates your trigger output to run the automation.