Workflow mailing issue

Hi there. 

I have an issue that is not covered in the FAQ.

My workflow (permission is set to unrestricted) action is supposed to send an email.

Most mail addresses work however, the mails on my office domain do not: 

I have asked my IT manager if he sees anything blocked on my side. He assures me that the mail never came through. I have checked my junk mail to no avail either.

The interesting thing is that the Smartsheet mails from "" always work to any valid email address but the mails that come from "" fail to deliver to any work email address


Thank you



  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Graham Audouin

    Can you ask your IT manager to ensure that all the domains listed in this Help Article are on your organization's allow list? Issue: Email Not Received from Smartsheet

    Additionally, you may want to check to see if your personal notification settings are turned off for these types of alerts:



  • Hi @Genevieve P.

    Thank you for your response. I have checked with my IT manager and all the domans are listed in the allow list. There are no blocked domains either.

    Those suggested setting are also applied.

    Still, no joy.

    I see a "Domain & User Auto Provisioning" section but you have to be an "Enterprise" user. I am a "business" user". Could it have anything to do with that?

    If not, do you have any other suggestions?

  • @Genevieve P.

    Surely "" should also be on the allow list. I see that is not listed

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Graham Audouin

    Thanks for checking with your IT team. is part of the allow list, so this should let through emails coming from as well.

    The Auto Provisioning has to do with automatically adding Smartsheet accounts as members of your Smartsheet plan based on their domain, so no, this won't have to do with your current issue.

    Troubleshooting Questions:

    • Is it just this one specific workflow that is not sending an email, or are no alerts getting through?
    • Do you receive the alert in the Bell Icon in Smartsheet (the notification center)?

    If it's just one workflow:

    • Can you try creating a clone of the workflow?
    • If this hasn't worked, can you post a screen capture of the workflow set-up and a screen capture of the underling sheet (blocking out sensitive data), and a final screen capture of the Permission settings for an example user not receiving the workflow (the same as the screen capture I have above).