Card View behavior in WorkApps

Kyle Morgan
Kyle Morgan ✭✭✭✭✭
edited 06/07/23 in Add Ons and Integrations

Hi all,

I have created a WorkApp for our Graphic Arts Department.

It contains approx 6 pages of Card Views. All of the pages are generated from the same underlying sheet.

The underlying sheet contains several filters (ex: "by Designer", "by Product Category", "by Priority" and so forth). There are also several projects that have Parent / Child rows.

I have set up individual pages in the WorkApp based on each of these filters. (There is a page named "By Designer", "By product category" etc) Each page was set up using the page settings within WorkApps : i.e "Desktop View" is set to "Card View"

This works as it should. Our users access the WorkApp and select the view they want by selecting the appropriate sheet.

The issue I am having is that many of the cards have subtasks and I am attempting to set the default view to Level 1 so that the subtasks don't clutter up all of the views. However, it does not appear to be working.

When I (owner of the WorkApp) access the App, it functions as intended. All pages default to the appropriate View and only the Level 1 cards are visible. I can access all of the subtasks from the individual cards etc.

However, other Teammates are reporting that all subtasks (Level 2) are still visible upon opening each page. These users all have full view / edit access to the sheets.

How do I get all pages to default to level 1 for all users? I have tried everything that I can think and just can't figure it out. I have spent so much time trying to find a solution that I am afraid that I may have just gotten too close to it and am overlooking something very basic. Your help would be greatly appreciated. If this is something that isn't possible (and the lack of being able to @mention people) I may need to scrap WorkApps entirely. There seems to be some missing "basic functionality" in the WorkApps ecosystem.

Thanks in advance!



  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Kyle Morgan

    Your settings are correct for what you're looking to do.

    In my testing, the first time I set the Card Level it showed me both Level 1 and Level 2 like what your users are seeing. After going back to the Workapp, adjusting the Levels to 2, then 3, then back to 1 and Publishing it again, the Levels then worked as expected and only Level 1 showed for all collaborators.

    Can you try re-setting it, and re-publishing the Workapp to see if this helps to refresh the Card View settings?

    If this still hasn't helped, please take a screen recording of the behaviour you're seeing and contact Smartsheet Support with as much information as possible.

    Thank you,


  • Kyle Morgan
    Kyle Morgan ✭✭✭✭✭

    Thank you so much, Genevieve

    I tried adjusting and republishing (per your suggestion) numerous times with no success.

    I'll reach out to Support to see if we can find the Gremlin(s).

    I appreciate your help in trying to find a solution.

    All the best,