Trouble Integrating Smartsheet with Salesforce CPQ: DataSync Error

Hello Smartsheet community,

I am currently working on integrating Smartsheet with Salesforce CPQ using DataSync. However, I am facing an issue that is causing the integration to fail.

Here are the details of the problem:

  • I am using DataSync to synchronize data between Smartsheet and Salesforce CPQ.
  • The integration was working fine initially, but suddenly, I am encountering errors during the synchronization process.
  • The error message I'm receiving is "DataSync failed: Unable to connect to Salesforce CPQ API."

I have already checked the following:

  • The credentials for the Salesforce connector are correct.
  • The API access is enabled in Salesforce CPQ.

Despite these efforts, I'm still unable to establish a successful connection between Smartsheet and Salesforce CPQ.

Has anyone else experienced a similar issue while integrating Smartsheet with Salesforce CPQ using DataSync? Any insights or troubleshooting tips would be greatly appreciated. I have already checked this CPQ Course

Thank you for your assistance!


  • Hamza1
    Hamza1 Moderator

    Hi @stevediaz

    I believe contacting the Support team through the customer support portal is the better route for your query so we can help troubleshoot the issue in a private channel and provide assistance. Please provide the following information in your ticket:

    • Screen recording of the steps you’re taking and the error message
    • Approximate date and time stamps (including timezone of the error message)
    • Whose Smartsheet credentials are you using to set up the connector (email)
    • Tried a different Smartsheet user?
    • Whose credentials are used for SF (email)? 
    • Tried a different SF user?
    • SF URL: 
    • At what step are you having issues?



  • stevediaz
    edited 08/31/23


    Thank you for your response and suggestions.

    I have taken note of your advice and will consider reaching out to the Support team through the customer support portal for further assistance. I will provide them with the requested information, including a screen recording of the steps I'm taking and the error message, along with the date and time stamps when the error occurred.

    The issue seems to occur during the synchronization process when DataSync is attempting to connect to the Salesforce CPQ API. The error message displayed is "DataSync failed: Unable to connect to Salesforce CPQ API.

    I appreciate your help and suggestions.

    Thank you.