API: Missing userPermissions and workspace fields in get_sheet response

akhalid ✭✭✭
edited 01/07/24 in Add Ons and Integrations


I have been using Smartsheet API for a while. I invoke my Python scripts to read sheets and do all sorts of stuff.

I created a new developer account recently. Then I created a new sheet and tried to read it using my scripts. I realised that the response is not returning the field userPermissions which is usually returned as such:

"userPermissions": {"summaryPermissions": "ADMIN"}

Another field that I found missing is the workspace which is usually returned as such:

"workspace": {"id": 1234567890, "name": "My Workspace"}

  • If I share a sheet created from my previous account with my new account, they contain those two fields
  • I shared this new sheet with my other account and the behavior is still the same (i.e. missing fields)

URL that I am hitting: https://api.smartsheet.com/2.0/sheets/1234567890?include=crossSheetReferences,format,ownerInfo

What could be the reason for the missing fields?