Data Shuttle Overwriting Destination Fields I Don't Want Overwritten

I'm using data shuttle to move data from a source excel sheet to a destination smartsheet based on mapping fields to columns. There are two smartsheet columns I do not want overwritten and have selected those on the source side as Do Not Map in the data shuttle workflow config. The only choice for workflow action that makes sense is "Replace all Target sheet rows with the data from the input file", because I'm selecting which fields in those rows to map. However... each time I run the workflow, the pre-existing "Do Not Map" fields in the destination smartsheet end up blank as if the entire row is being overwritten (since nothing is in those fields in the source sheet.)

I had a ProDesk call a little while ago and was assured you can overwrite/map and not overwrite/no map fields easily, so this should be doable. (Should have live tested the behavior... but didn't) Any ideas? Thanks ! Mike


  • MichaelTCA
    MichaelTCA ✭✭✭✭✭✭

    Hello @mikemiller1000

    I believe it will delete the entire sheet and then add all the new data in one foul swoop. I did the same thing and had to recreate the sheet because I had tables and analytics in a few random columns on the side that were not mapped.

    Otherwise you will need to use the update option.

    If there's data you don't want on the log, create an archive with a procedure to move them off of what you're working with, using automations. I recommend setting a schedule so that the automation will move the data you don't need prior to updating the sheet with data shuttle.

    The filters will look at the source file being imported, so maybe just a filter will help to add/update/remove. Filters will not look at the target file though, which means you can't set filters in data shuttle by any of the expressions that you use within data shuttle.

    Something like this. Maybe without the add rows if you have a different way to enter in the data you are using to reference in data shuttle.

  • HI Michael,

    Thanks for the thoughtful suggestions. Fortunately I have an option to move the fields that are being overwritten on the designation sheet to the source sheet. I can hide them and users will be none the wiser. Not as elegant, but a stop gap for now.

    It still doesn't make sense to me that the data shuttle config allows a combination of "mapped" and "Not mapped" fields in association with the "Replace all Target sheet rows..." workflow action and yet end up with the result I'm getting.

    If I've specified the last two destination sheet fields below to be "Not mapped", why are they being overwritten?