How to make Metric Widget Align the Data?

Options
Pauline J
Pauline J ✭✭✭✭✭
edited 05/16/24 in Smartsheet Basics

I have a metric widget to display the number of submitted items. But it drops the value below the line of the field title. I have manipulated font size, removed the widget and re-constructed … to no avail. What am I missing? Thanks in advance!

Best Answers

  • dojones
    dojones ✭✭✭✭
    Answer ✓
    Options

    Pauline,

    I'm not sure what is causing it. I would try create a basic sheet with a summary, then put it to a new dashboard to see if it still occurs. If it doesn't, there is something in the sheet/dashboard causing it. Otherwise, it is your installation of Smartsheet. I couldn't make it happen. If you are paying for support, try there.

    As far as getting the table view, having the pivot app is the easiest way, but it's an add on. Otherwise, it's more complicated using helper columns, metric sheets with formulas and displaying on a report

    Best of luck on getting to a solution.

  • Pauline J
    Pauline J ✭✭✭✭✭
    Answer ✓
    Options

    As a followup to anyone else who finds this same problem, Smartsheet support said that it is a bug — not fixable at this time.

Answers

  • dojones
    dojones ✭✭✭✭
    Options

    If it's just one value, under Data and Layout, select Side-by-Side. If you don't want the Title, turn titles off.

  • Pauline J
    Pauline J ✭✭✭✭✭
    Options

    @dojones

    Thank you for responding. Yes, it's one value but when I display it side-by-side, the value drops, as shown in my image above. The fonts are the same, and the same size. I've tried manipulating it by changing the number font to a smaller font, or the label to a larger font … it just will not align. The title is fine — it's the number to the right of the "Submitted" that's not aligning.

  • dojones
    dojones ✭✭✭✭
    Options

    I can't make that happen on my end. My data is coming from a summary sheet. Where is your data coming from?

  • Pauline J
    Pauline J ✭✭✭✭✭
    edited 05/06/24
    Options

    @dojones I have tried both methods. This is what I want it to look like:

    I have tried using data from summary fields, tried using a report … I changed my formulas in the summary sheet to grab both the Month and the number, but that looks like a date. I added multiple spaces inbetween the month and the number — but SS only honors a single space. Fonts are the same typeface, same size.

    If I put them in as separate reports/shsets, then I have to have the massive white space between the rows.

    This is what it looks like after it is saved, without touching the widget — it dropps the numbers down.

    I get the same output whether I am using a summary report, the sheet, or summary fields on a sheet …. as soon as I select save — it mis-aligns the rows.

  • dojones
    dojones ✭✭✭✭
    Answer ✓
    Options

    Pauline,

    I'm not sure what is causing it. I would try create a basic sheet with a summary, then put it to a new dashboard to see if it still occurs. If it doesn't, there is something in the sheet/dashboard causing it. Otherwise, it is your installation of Smartsheet. I couldn't make it happen. If you are paying for support, try there.

    As far as getting the table view, having the pivot app is the easiest way, but it's an add on. Otherwise, it's more complicated using helper columns, metric sheets with formulas and displaying on a report

    Best of luck on getting to a solution.

  • Pauline J
    Pauline J ✭✭✭✭✭
    Options

    @dojones Thanks for the reply — we do have support, I always assume it's something I'm not doing properly. Ha. I appreciate the time you spent very much!

    Pauline

  • Pauline J
    Pauline J ✭✭✭✭✭
    Answer ✓
    Options

    As a followup to anyone else who finds this same problem, Smartsheet support said that it is a bug — not fixable at this time.