Smartsheet Integration with Gmail

Shaine GreenwoodShaine Greenwood Employee
edited 09/05/18 in General Announcements
10/24/17 Edited 09/05/18

Smartsheet Community,

You can now add email message content (subject, body, attachments) to rows in a sheet without having to leave your Gmail inbox.

Check out the help article for more information on the Smartsheet Integration with Gmail.

Comments

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    FYI

    ***NOTE: Google is aware of, and is working to address, an issue which is preventing GSuite administrators from installing Gmail Add-Ons, including the Smartsheet for Gmail Add-On. ***

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • bmezgerbmezger ✭✭✭✭✭

    Is there any ETA on when Google will resolve the issue with GSuite Admins ability to install the add-on?

  • Jason KoscinskiJason Koscinski ✭✭✭✭✭

    Waiting here too, the admin me is the main sales guy so it's kinda big deal 

  • Still waiting - any timeline on this?

  • Hi All,

    Thanks for your patience.  Last we heard from Google, they were expecting to release an update that will allow GSuite Admins to install Gmail add-ons for themselves and their entire GSuite group in the first week of January.  We'll send updates as soon as we have them.  Thanks again.

  • DustinDustin Employee
    edited 01/09/18

    Google has released this update and it is now live: Admins can install the Smartsheet for Gmail Add-on domain wide!

    Please let us know if you have any questions throughout the process; we look forward to supporting you and all your users to help manage work from Gmail and move from ideas to execution faster!

  • Hi All, 

    I just installed as admin & it's not showing up anywhere in gmail, even after a refresh & a reboot. What am I missing here? 

    Thanks!

     

  • Just to say it is working for us - and did show across our domain

  • Hello,

    Please reach out to our Support team to troubleshoot further. There may be other factors causing this that our Support team can troubleshoot with you..

  • Hi TRmelissa, thanks for letting us know.  In a couple cases other GSuite admins have reported a time delay on the order of a few hours for the add-on to appear following installation.  The delay has been reported despite browser refresh or device reboot.  So hopefully the add-on will appear for you later today!  Let us know when it does!

    Best,

    Scott

  • I am having the same issue in Chrome. The problem I found is that I have other extensions installed in the Gmail Suite and the icon for Smartsheet is hidden behind the icon for the other add-ons I have installed.

    You should check your Gmail extensions and temporarily turn them off to see if that displays the Smartsheet icon.  To manage your extensions, click on the upper right hand corner of Chrome and look for the three dots, click on "More Tools" and then "Extensions". You can temporarily uncheck the ones that could be interfering with Smartsheet and refresh the tab in your browser with your Gmail. Open an email and see if you find the Smartsheet icon on the right hand side. If so, that is the problem.

    Unfortunately, my other add-ons are priority so I cannot turn them off but Smartsheet should fix this problem or they will be competing with other extensions. 

    I hope this is fixed as I would love to use it!

    Smartsheet Extension Issue.png

  • TRmelissa:

    Do you have any other Gmail extensions? If so, that could be the problem. Is happening to me as well. I have a Hubspot extension so the Smartsheet icon is not displayed because is behind the icon of my Hubspot add-on. In other words, extensions compete for the same real estate in the Gmail panel so you only see one at the time. What a shame!

    In Chrome, on the upper right hand corner, click on the three dots to open the menu, then click on "More Tools" then "Extensions". See which ones you have installed and uncheck the ones you think maybe interfering with the Smartsheet add-on. Once you uncheck them, refresh your Gmail tab and open an email to see if you see the Smartsheet icon. If so, that is the problem.

    I hope this is resolved soon because I would like to use it but I cannot eliminate Hubspot as I use it daily.

    I hope that helps!

Sign In or Register to comment.