Filter default

Jroeder ✭✭✭
edited 12/09/19 in Smartsheet Basics

Is there a way to save a filter as the default. I want the same filter applied every time the sheet is opened without the need to select it.

Best Answer


  • Nadia

    Hi there,

    I'm not sure what info you have on your sheet, but reports allow you to set a default filter. 

  • Mike Wilday
    Mike Wilday ✭✭✭✭✭✭

    If you apply a filter and save the sheet it should reload the sheet with the same filter applied. However, this works on an individual users view of a sheet. Filters are not forced across user views to other users. Other users see the plain data and have the choice to filter it for themselves, or not. 

  • Mike Wilday
    Mike Wilday ✭✭✭✭✭✭

    By Golly! You're right! Completely buried, but it's there! :) 



  • Jroeder
    Jroeder ✭✭✭

    That's what I needed. Thanks Steve!

  • Michael Barker

    My sheet contains several filters, yet when I open Default View the only option SmartSheet gives is "None." Is there a fix for this?

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭
    edited 03/06/20

    Hi Michael,

    @Michael Barker

    Can you describe your process in more detail and maybe share the sheet(s)/copies of the sheet(s) or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too,

    I hope that helps!

    Have a fantastic weekend!


    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    ✅Did my post help answer your question or solve your problem? Please help the Community by marking it as the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: | | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Mitchell Munoko

    I know Michael's last question was posted a while back, but for anyone that may still be looking for the answer: only shared filters will show on the dropdown. So make sure "Share filter" is checked on the one that you want to make the default. You will need to save the smartsheet after making the update for it to appear.