Percent Formatting applied, but entry of 100 is shown as 10,000%

edited 12/09/19 in Using Smartsheet
04/12/19 Edited 12/09/19

I have the entire column formatted as a percent, but when I enter 100, it shows as 10,000%, or when I enter 1 it shows 100%.  Would like for the number entered to show that percent. 

percent.PNG

Comments

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Hi Randy,

    You probably need to change the decimals (see attached screenshot)

    Did it work?

    Have a fantastic weekend!

    Best,

    Andrée Starå

    Workflow Consultant @ Get Done Consulting

    Image 2019-04-12 at 6.50.48 PM.png

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • No that did not work.  Moving decimal to the left does nothing and moving it to the right just changes it to 10,000.00%

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    SS recognizes percentages as a fraction of 1. So 1 = 100%, 0.5 = 50%, 0.25 = 25%, so on and so forth. If you have the column formatted as percentage, you will need to enter the decimal equivalent.

    thinkspi.com

  • Andrée StaråAndrée Starå ✭✭✭✭✭
    edited 04/12/19

    Seems to be a bug.  There was a delay when I tested but now it works as intended! 

    It happens when the values are already in the cells when you apply the percentage format. If I set the percentage format and then add the values, it doesn't happen.

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • No my issue is actually when a new value is typed in.  I was using Internet Explorer, just tested in Chrome and it does not persist.   

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    It was a little strange here also so maybe it was a short glitch. I'll try later again. 

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    I tried it again in both Chrome and Safari and it's working as it should.

    How did it go for you?

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • M. DavidM. David ✭✭✭✭✭

    People in my company have been having this same issue. I noticed that it was happening for some people but not for others. I don't know how to fix it as I think there might be a glitch that needs to be fixed with the software, but I have been able to replicate it.

    We have a "% Complete" column. This is a text/number column that has had "%" formatting applied to it. If you type in any number, the "%" symbol pops up. If you hit enter, that number will stay with the symbol staying with it. If you input "100" and then hit delete to remove the percentage symbol and hit enter, it will change to 10,000%. I've confirmed with one colleague that this happens to her, but not with the ones who notified me of the issue to begin with. I will update when I hear more. 

  • Similar problem - see snapshot.  Even tried copying the same cells to a blank section of the same sheet - didn't help.  All the other "roll-ups" on the same sheet display as % - as it's supposed to.  Something is glitchen' here....

    Michael

     

    Won't roll up to percentage complete.jpg

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Have you tried clicking on that specific cell and formatting as percentage?

    thinkspi.com

  • Smartsheet acknowledged that this is a known bug in Internet Explorer.  Switch to Chrome corrected the issue.  or you can type the decimal equivalent (i.e. .5 for 50%)  

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Thanks for sharing Randy!

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • edited 10/13/21

    We've encountered this issue as well... found that if we highlight the contents of the cell to edit the value and do not include the '%' sign is when the value gets reformatted to be x1,000 the original value. If you just enter the new value directly into the cell vs. first clicking in to highlight the value the x1,000 does not happen.

Sign In or Register to comment.