Row Change Notification Being Triggered by Rows Added Through Form

01/07/20
Answered - Pending Review

Hi there


I've setup a notification that's triggered by a row change. However when a new submission is made via the form (i.e. a new row is added via the form) it's triggering the notification as well.

The notification is:

"Trigger: When rows are changed AND when column1 changes to any value, or when column2 changes to any value Actions: Alert all shared users"

Can anyone help me πŸ™†β€β™‚οΈ:)


Thanks,

Elisha

Answers

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Are you able to provide a screenshot of your Automation itself?

    thinkspi.com

  • Hi Paul


    I've attached two photos.


    There's a lot of triggers so it wouldn't fit in one pic.


    Thanks,

    Elisha


  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Ok. So I am going to suggest reaching out to support on this one, but first I do have a bit of an idea...


    Do you have any formulas that are running on each new row that get autofilled down?

    thinkspi.com

  • Hi Paul


    Thanks.

    No, there are no formulas at all in the sheet.


    Elisha

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Hmm... Ok. Well there goes that theory. Haha.


    I am going to suggest reaching out to support because it doesn't seem like it should be working that way based off of your setup.


    I agree with you that a form is adding a new row, not changing an existing row. Which means a form entry shouldn't be triggering a "when a row changes" workflow.

    thinkspi.com

  • Ok. Thanks a ton for your help/advice.


    Elisha

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    Happy to help! πŸ‘οΈ


    Please don't forget to revisit this thread with the outcome so we can know whether this happening is intended or not along with whatever solution is found.

    thinkspi.com

  • will do.

  • I am also having this same issue. Row changed notification is being sent out when rows are added via form. Was there a resolution to this?

  • Paul NewcomePaul Newcome ✭✭✭✭✭

    @Anna Lee How is your trigger set up?

    thinkspi.com

  • I am having this issue as well and have found a culprit! Note that there could be more culprits, but this one is repeatable and is tied to Approval Requests.

    In a very simple sheet, I have 2 Automations:

    1. When rows are added and 'Column1' has any value -> Send approval request
    2. When rows are changed and Column2 changes to any value -> Send alert

    When both of these Automations are enabled and a new row is added, #1 is triggered immediately. And #2 is triggered one or two minutes later. This is consistently the bad behavior.

    When the Approval Request Automation is disabled and a new row is added, neither automation is triggered. This isolates the problem, but I still need both Automations to run independently for proper functionality.

    I am happy to share a link if anyone wants to put another pair of eyes on this. Or otherwise, is there a proper channel for submitting a bug report to Smartsheet?

Sign In or Register to comment.