Data Uploader - Error message "Array attributes may not contain null elements:"


I've been wracking my head for several hours and still cannot figure out what I am doing to receive the following error message when I run my workflow (even when using merge and replace)

In my source attachment there are 26 columns (one is system generated so won't import anyway) and in my target sheet there are 41 columns.

I have mapped all the source columns to the respective target sheet columns so that it matches up. Even when I managed to make it run it recognised the 219 rows of data but just skipped over them. I have even tried copying some of the data directly into the target sheet (mainly the specific ID) to see if that would help but I am still getting the error message.

As the source sheet is compiled by users, they do not need to fill in every column which means there are some gaps so I tried to replacing all the gaps with "." just to see if that would work.

Any help or direction would be greatly appreciated!



  • Genevieve P.
    Genevieve P. Employee Admin

    Hi Paul,

    When I've seen this type of error before it has to do with the column headers; have the column headers changed at all since you first set up the workflow?

    Please double check and ensure that the column headers in the workflow mapping match the column headers in the most recent file used, and that none of the headers in the target sheet have been adjusted.

    If this is not the cause of the error, you may want to reach out to Smartsheet Support so they can look into it further for you (confirming that you have already checked the headers).



  • Hi Genevieve,

    I have just run into the exact same issue and its cause information to not populate on our intake sheet. None of our columns have been changed. Any other thoughts or ideas on what could be happening?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Joseph Bartlow

    If you can confirm that the column headers/titles haven't changed at all, but you're receiving this same error... please do reach out to Smartsheet Support so they can look into this with you!

    The only resolution I have personally tested and resolved when it comes to this specific error has been column headers.

  • Julia C Peterson
    Julia C Peterson ✭✭✭✭

    This has happened to me when I create the DataUploader and then make modifications to the columns in either the smartsheet or source excel file. Sometimes DataUploader doesn't recognize the changes so the current columns aren't even available in the DataUploader settings. Even when they are, it sometimes still doesn't work for whatever reason. In those situations, I just start over with a new DataUploader. Even if the settings are identical to the one getting the error messages, the new one works and the old one doesn't. In the end, this can be more time effective then trying to fix the old one or reaching out to smartsheet support.