Dynamic View

Lori AlthouseLori Althouse ✭✭✭✭✭
06/23/20 Edited 06/23/20
Answered - Pending Review

I am trying to use dynamic view for clients to approve their own tickets that are coming through. I have shared the dynamic view via the domain name - but the users in that domain cannot see anything in the dynamic view. I have tried it myself and it works fine. Any thoughts or ideas?

Answers

  • Hi Lori,

    If the users are able to see the name of your Dynamic View and can access it, then it sounds like the sharing has worked properly, but that there is something to do with how it's set up that makes them see blank rows.

    Have you restricted the view by Current User? If so, check the column you're using as the restriction to see if those who are seeing a blank view have any content. If their contact isn't in that column yet, they won't see any rows in the view since there's nothing associated with them.

    Here's an image of the Current User restriction, and the filter option as well. You can find this at the bottom of the first "General" page of the settings:


    Here's more information on Dynamic View & Current User.

    Let me know if this was the issue or not! If not, it would be helpful to see screen captures of what you see vs. what they see, if possible (but block out any sensitive data).

    Cheers,

    Genevieve

  • Lori AlthouseLori Althouse ✭✭✭✭✭

    Genevieve - thank you so much for responding. Here is what my general settings look like for this dynamic view. I only wanted each user to see the rows that contain their email address in the contact column "E-mail address". The users do have content in the sheet - I have checked that. I am double checking to make sure the email address in this contact column is the email address they are using to log into Smartsheet - I am pretty sure it is. The screen shot I received shows that they can access the dynamic view - it just does not contain any rows - like I thought it would. When I read the choice above - "No restrictions - all rows visible to everyone shared" it looks like they will be able to see all rows - which is not what I would like to happen. I only want them to see their rows that contain their email address. Let me know what you think - thanks again for your help.


  • Hi Lori,

    Based on what you've described, it looks like you've set it up correctly then! Yes, getting the users to check that the email address they log in with is the same as what's in the Contact Column is exactly what I would have suggested next.

    The next thing to check would be how your View Display and Details Panel are set up. As such, this might actually be better dealt with by our Support team, so they can have visibility into your sheet & Dynamic view to troubleshoot with you.

    If your users come back and confirm that the email they use to log in is the same as what you have in the "E-mail Address" column but still can't see any rows, please create a Support Ticket Here. It would help the Support team to know the name of your source sheet and any additional screen captures (such as the View Display & Sharing page in the Dynamic View settings, and the source sheet in Grid View).

    Thanks!

    Genevieve

  • Lori AlthouseLori Althouse ✭✭✭✭✭

    Hi! Thanks again for your help. I will wait to hear back about the email addresses - and then put in a support ticket accordingly. Appreciate your responses very much. Stay safe and have a good day.

    Lori

  • No problem!! Let me know how it goes 🙂

    I hope you stay safe & have a good day as well.

Sign In or Register to comment.