Document Builder - date format?

Robin Sugiura
Robin Sugiura ✭✭✭✭✭✭
edited 06/14/22 in Add Ons and Integrations

I am trying to generate certificates of completion with document builder and include the date of conferral. No matter how I enter the date into a date field (my preference is "Friday, January 1, 2021" as the format), it always enters in the 1/1/21 format. Any ideas for getting document builder to fill it correctly?

Best Answer

  • Robin Sugiura
    Robin Sugiura ✭✭✭✭✭✭
    Answer ✓

    I figured out a workaround -- if the date is entered in long form in a text column instead of a date column, it populates as entered.

    Don't know if there is another way to affect the formatting if populating from a date column.

Answers

  • Robin Sugiura
    Robin Sugiura ✭✭✭✭✭✭
    Answer ✓

    I figured out a workaround -- if the date is entered in long form in a text column instead of a date column, it populates as entered.

    Don't know if there is another way to affect the formatting if populating from a date column.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Robin Sugiura

    Excellent!

    Glad you got it working, and thanks for sharing the workaround.

    Be safe and have a fantastic week!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Please help the Community by marking your post with the accepted answer/helpful. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • I am struggling with the same issue listed in this thread, however my problem is that I cannot add the date as a text because there are other columns that automatically calculate from the date column. Can I somehow copy the date into a text column without running into a formatting issue?

  • Robin Sugiura
    Robin Sugiura ✭✭✭✭✭✭

    Yes, I had to add a helper column and have to add the long form version manually. It's a crap workaround.

  • Hi All. I had a similar problem in that I wanted to display the modified date in long format. I solved this problem by building a sheet with months (column 1 has numbers 1 to 12 and column 2 has the month name). I then used a new column in my sheet which had the following formula =DAY([email protected]) + " " + VLOOKUP(MONTH([email protected]), {Months Range 1}, 2, false) + " " + YEAR([email protected]). This returns text in long format and i use that in my document builder. Its pretty clean and easy to use. Would be nicer if we could simply format in "long" though :)

  • I find the document builder extremely frustrating from a formatting perspective, this being one of them. The workarounds are not consistent with what they are presenting the features to be - its much less simple that its trying to seem. My formatting is coming through is various stretched out sized, text cut-off in the form field, etc. There needs to be a formatting edit feature that affects the document only, and not needing the source sheet to have the same format (text alignment, font size, etc)

  • SueinSpain
    SueinSpain ✭✭✭✭✭✭

    I was having date format problems and found it was because the format is taken from the PDF file not the smartsheet. So I did a custom date format in my adobe fillable pdf and yippee it worked.

    I haven't ried all variations or the very long date but it did make me aware that the PDF formatting overrides the smartsheet formatting


    Hope this helps :)

  • Nicolas Michel
    Nicolas Michel ✭✭✭✭✭✭

    @SueinSpain I'm interested in which date format you used. I've tried what you mentioned. I modified the fields in the pdf to date DD-MMM-YYYY (same as my column date format in the sheet), remapped it but the form generated was still showing the date in DD/MM/YY (in Europe) and MM/DD/YY for my US colleague.😕 It looks like the date regional settings is the default format used for the date column when generating a document.

  • Kirstine
    Kirstine ✭✭✭✭✭✭

    Mine is creating the document with American format even though I'm in the UK. 😩

    Can you help @Andrée Starå ?

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Kirstine

    I hope you're well and safe!

    How did it go? Did you manage to get something set up?

    I hope that helps!

    Have a fantastic weekend & Happy New Year!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Kirstine
    Kirstine ✭✭✭✭✭✭

    Hi @Andrée Starå

    I still can't get it to do a long date, but I did a ridiculous workaround with three helper columns which at least brings it up in English format. (I needed mine entered at the end of the sentence so I had to add a full stop/period afterwards.)

    Date_helper1: =([Start Date]@row) + " "

    Date_helper2: ="."

    Date_helper3: =LEFT([Date_helper1]@row, 8) + [Date_helper2]@row

  • I have updated both the PDF format to be mmmm dd, yyyy and changed the smartsheet format to be long format and the date in the document generator is still showing up mm/dd/yy