Automation changes?

Jennifer Kaupke
Jennifer Kaupke ✭✭✭✭

I had an automation setup to copy a row from one sheet to another that has suddenly stopped working. The trigger sheet lives in a different workspace from the destination sheet but that has always been the case. I am an admin on both workspaces.

When I attempt to fix (or even create a new) the trigger, the list of available sheets to send the copied row to are only those within the same workspace.

Did something change about automations that no longer allows automation between sheets in different workspaces? (it was working for several months)

😓

 Is there something else I could be missing?

Thanks!

Best Answer

Answers

  • Antonio Figueroa
    Antonio Figueroa ✭✭✭✭✭✭

    It is working on my end. You might have accidentally unsubscribed to that workspace and or sheet.

    Also check to see if the owner of the workspace did not remove you from the shared list. This can Prevent you from accessing a workspace.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Jennifer Kaupke

    I agree with @Antonio Figueroa, it sounds like you may have been un-shared to a number of sheets, or the owner of the original sheet has been removed from the destination sheet. You can only create Copy or Move row workflows between sheets where you and the owner are shared to both sheets. (See the Note in this article: Automatically Move or Copy Rows Between Sheets)

  • Jennifer Kaupke
    Jennifer Kaupke ✭✭✭✭

    hmmmm.... I am the owner of one workspace & sheet (receiving) and I am the admin of the other workspace & sheet (sending) so I don't believe that is the problem. I ended up just making a copy of the sheet and archiving the old version. Solved the problem but still stumped as to why that happened in the first place. Thanks all!

  • Genevieve P.
    Genevieve P. Employee Admin
    Answer ✓

    Hi @Jennifer Kaupke

    Could it have been that the owner of the sheet (sending) where you're an Admin was removed from the workspace or sheet that was receiving the rows?

    In any case, glad you were able to sort it out!

    Cheers,

    Genevieve

  • Jennifer Kaupke
    Jennifer Kaupke ✭✭✭✭
    edited 03/19/21

    @Genevieve P BINGO! The owner of the sending sheet is an editor of the receiving sheet but not an admin. As soon as I made her an admin of that sheet, it worked again! It makes complete sense now because it stopped working when the owner changed and the previous owner had admin rights!

    Thank you!!

  • Genevieve P.
    Genevieve P. Employee Admin

    No problem! I'm glad we were able to figure it out. 🙂

  • Cathy Betzer
    Cathy Betzer ✭✭✭✭✭

    Following up on this thread. I have a user that is an Admin on both the sending and receiving sheets. The sheets are in two different workspaces. We want to copy a row from one sheet to another to trigger a new set of automations. When we try to link the sending sheet via automation to the receiving sheet it is not in the list of available sheets. Similar to what user noted above. Do the two sheets have to be in the same workspace in order to copy rows? The permissions of Admin should be sufficient. Any ideas?

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Cathy Betzer

    The sheets can be in different Workspaces, that's not a problem! 🙂

    If the user creating the workflow is only an Admin, you'll need to make sure that the Owner of the sending sheet is also a shared Admin on the receiving sheet as well.

    Essentially think of it like the Admin cannot steal rows away from the Owner without their visibility to where the rows are going.


    For example:

    Genevieve's Sheet - Genevieve = Owner, Cathy = Admin

    Joe's Sheet - Joe = Owner, Cathy = Admin

    In this scenario, Cathy cannot create a workflow to take rows from Genevieve's sheet and move them to Joe's sheet. This is because Genevieve does not exist on the second sheet. Try updating the Owner to be an Admin on the second sheet as well:

    Genevieve's Sheet - Genevieve = Owner, Cathy = Admin

    Joe's Sheet - Joe = Owner, Cathy = Admin, Genevieve = Admin

    Now Cathy can move rows from Genevieve's sheet to Joe's sheet without an issue!

    Cheers,

    Genevieve

  • Cathy Betzer
    Cathy Betzer ✭✭✭✭✭

    Thanks for your input. In my scenario it is not working:

    Origination sheet - owner is Lisa - she's an admin on Receiving Sheet

    Origination sheet is not in a workspace but in general "sheets" folder.

    Receiving sheet is in a workspace and Lisa has Admin rights to the receiving sheet.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Cathy Betzer

    Thanks for clarifying!

    If the Owner is an Admin on the second sheet, and the user creating the workflow is an Admin on both sheets, then you're absolutely correct: the second sheet should appear when creating the workflow.

    The other time I've seen this happen is when the sheet was created within the last 10 minutes; the workflow list of sheets hasn't had time to re-index all of your sheets available. Logging out / in again should resolve this!

    If that hasn't helped, you may want to troubleshoot this in a private channel with Support. They'll need to know the email address of the user creating the workflow and both sheet URLs.

    Thanks!

    Genevieve

  • Cathy Betzer
    Cathy Betzer ✭✭✭✭✭

    Thank you, Genevieve. I've opened a support ticket.