Document Builder - Generating documents removing formatting

Hello,

I'm fairly new to Smartsheet and have been learning as I go.

The issue I am encountering is that when I Generate a document into a fillable PDF, I lose my line breaks and everything gets compressed into one paragraph.

I have multi-line enabled for the PDF fields and have tried both Ctrl + Enter and CHAR(10) in the formula that is compiling the the data. Everything looks great in Smartsheet, but the PDF is missing the line breaks.

I tried my best to research, but I can't seem to figure this out.

Thank you for your help!

Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @Ana Tongen

    I hope you're well and safe!

    Strange!

    Have you activated the Wrap feature in Smartsheet as well?

    If you add text manually to the PDF, does it show on multiple lines?

    Can you describe your process in more detail and maybe share the sheet(s)/copies of the sheet(s) or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    I hope that helps!

    Be safe and have a fantastic weekend!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Andrée, Thank you for getting back to me.

    I have multi-line selected on the pdf form and wrap text enabled on all of my columns in the sheet.

    When I copy paste from the column to word or into the PDF form the line breaks are visible, but when it is generated as a document from Smartsheet, the line breaks are eliminated.


    Thank you,

    Ana