Data Shuttle / Not connecting to source file

Having an issue where Data Shuttle does not seem to fully connect with my source Excel file in OneDrive.

It allows me to select the target file and then save that setting, but when I get to the mapping portion it will not let me map saying that I need to select a source file.

Has anyone else seen this behavior? (Attachment included..)





Thanks!

Best Answer

  • Dan Naugle
    Answer ✓

    Thank you Genevieve,

    I found the issue and it might be a useful note for others...

    The file is saved to OneDrive using a Microsoft Power Automate workflow. That workflow is for some reason adding an additional row to the top of the Excel spreadsheet as it is saved from an Outlook message attachment.

    This required that the Data Shuttle begin looking for the header on the second row. Once that setting was changed in the Data Shuttle setup, everything is working well.

    Thank you again!

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Dan Naugle

    The first thing to check is to ensure that your file in OneDrive is not stored in a Shared Drive (see: Data Compatibility).

    If it's in your personal OneDrive but you're still seeing this error, it may be that you've initially navigated away from the "Source" tab before the configuration had fully recognized the source file. Try staying on that tab for a minute or two before navigating to the Next step (timing may depend on your network connection speed).

    I would also recommend trying this from a different browser, or from Incognito mode as well. If none of this has helped, please capture a screen recording of the issue, showing all the different tabs in your Data Shuttle configuration, and contact Smartsheet Support so they can troubleshoot with you in a private channel.

    Cheers,

    Genevieve

  • Dan Naugle
    Answer ✓

    Thank you Genevieve,

    I found the issue and it might be a useful note for others...

    The file is saved to OneDrive using a Microsoft Power Automate workflow. That workflow is for some reason adding an additional row to the top of the Excel spreadsheet as it is saved from an Outlook message attachment.

    This required that the Data Shuttle begin looking for the header on the second row. Once that setting was changed in the Data Shuttle setup, everything is working well.

    Thank you again!

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi Dan,

    Thank you so much for detailing your solution, I'm sure this will be very helpful for others and I'm glad you were able to identify the cause.

    Cheers!

    Genevieve

  • I had the same issue for a file I was uploading that was saved in Microsoft Teams. Changing the header row solved it! Thanks Dan!

  • Hi Y'all,

    Anything on the Smartsheet roadmap re: allowing OneDrive shared accounts as a Data Shuttle source?

    While I can easily enough download a copy of the excel file from the OneDrive Shared folder and config a data shuttle to run on attachment, I'm doing this daily and providing the ability to sync changes from a Shared One Drive account allows me to fully automate the task.

    Let me know, thanks!

    Priya