Default value in Smartsheet Form will not save

I am trying to set a default value in a Form field and it will not save. I have tried both Edge and Chrome with the same result. The value provided in the drop-down are 0, 1 and 2. I want to set the default value to 0. In the past when I have experienced quirky issues like this I have recreated the sheet and that has resolved these types of issues in the past, as if the original sheet developed some kind of corruption. I'd prefer to not have to try that.


  • James Keuning
    James Keuning ✭✭✭✭✭

    Are you saying that you set the default to 0 in design view, and you can't save to get out of design view? Is the save button greyed out?

    Or are you saying that you can save the design, but when you open the form the zero isn't the default value?

    Have you tried to to recreate the form?

    My questions won't help solve the problem, but maybe they shed some helpful light on whoever else comes along.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @cheryl romano

    I hope you're well and safe!


    Can you describe your process in more detail and maybe share the sheet(s)/copies of the sheet(s) or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    I hope that helps!

    Be safe and have a fantastic week!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • Unfortunately I can't share the sheet due to company restrictions, I would have to submit a request to have your email address added as an authorized external user.

    I did attempt to create a new Form within the same sheet but the problem persisted. Specifically, in the Smartsheet I have a column entitled "How Many?" and then provide a drop-down that allows the user to enter 0, 1 or 2. Within the Form, I have this displayed as horizontal radio buttons. Under Default Value, I select 0 and it shows that number selected in the Form but when I save the Form, it resets back to blank.

    I am attaching a screenshot of the section of the Form I am referring to.

  • I have another update. Just for grins, I created a brand new sheet. I exported the original one and only imported the column headers. I only set up the How Many column to include the required values. I created a Form and attempted to modify that field to set a default value. Still didn't work, the setting will not save. Then, I created yet another Smartsheet and instead of importing the column headers I manually created one column for How Many, set the required values, created a Form, set the Default Value to 0, and got the same behavior. I'm starting to think there is a problem with Smartsheet at this point.

  • James Keuning
    James Keuning ✭✭✭✭✭

    When I pick my default as 0, I see this.

    Now, when I save, that Default Field reverts back to "Select" but the setting sticks.

    I feel like a call to Smartsheet might be needed.

  • TJ North
    TJ North ✭✭✭

    I encountered the same issue. I was able to discover the root cause. It is a bug with the software. You cannot select a default value that is a number. See also these threads, which report nearly the same issue:

    Smartsheet - in cases like this, it would be extremely helpful if you would publish a list of known bugs with their root cause and planned resolution date so that we can plan accordingly.