Data Shuttle Deleting all rows

Desirae Borge
Desirae Borge ✭✭
edited 06/14/22 in Add Ons and Integrations

My data shuttle is adding all the rows from the source file and then deleting them immediately. This workflow worked on Friday, and today it removed every row. I want only what is in the source file and to delete what has been removed. However, my source file is not blank. I've tried updating the workflow, but it keeps happening. Why is this not working?


  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Desirae Borge

    From these screen captures it looks like the workflow is running as expected - it's deleting the 278 rows in the sheet and replacing them with the 278 rows from your source data.

    Is there any possibility there's a second workflow on the sheet that is adjusting your information? For example an automation built into the sheet to Move rows, or another Data Shuttle flow?

    I would suggest contacting Smartsheet Support so that you can show more detailed information - screen captures of the source data and the target sheet, along with screen captures of each page of the workflow configuration.