DocuSign Integration Help

Hello,

New to DocuSign integration. Have gone through the mapping wizard, but when it comes time to actually drag and drop the Smartsheet fields to the PDF, I cannot do so.

I read through the Smartsheet instructions and noted that you have to update the Manage PDF form fill data option to assign to placeholder (see attached screenshot), but WHERE do I go to do this? Was excited to use this integration, but currently am not able to.


Answers

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @jl.furstenberg

    I hope you're well and safe!

    What happens? Do you get an error message?

    Can you share some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help.

    I hope that helps!

    Be safe, and have a fantastic week!

    Best,

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up, Awesome, or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.

  • jl.furstenberg
    jl.furstenberg ✭✭✭✭

    Hello Andree,

    I do not get any error messages, but I am unable to map any of the Smartsheet columns on to the e-sign PDF. The PDF appears without any fillable fields (screenshot Ex 2). I do not have the same issue when creating a regular PDF (using the same document, see Ex 1 screenshot), only when I go to create an e-sign PDF. My guess is there is an issue with permissions somewhere, but I am at a loss as to where.


  • Lesa Weaver
    Lesa Weaver ✭✭✭

    Hello @jl.furstenberg

    When we first started using Docusign we had some issues with the fillable PDF form that the instructions said to use. What works for us is to use fillable PDF form if using document builder without Docusign.

    If we are going to send the form through Docusign for e-signature, we use Word to build the form, convert it to a regular PDF, import it to Docusign, set up the Docusign fields for the template, then from the Smartsheet we go to document builder to map the columns.


    Hope that helps.

  • jl.furstenberg
    jl.furstenberg ✭✭✭✭

    Thank you! This does help. I appreciate it!

  • vdemattei
    vdemattei ✭✭✭✭

    When you say "set up the Docusign fields for the template", don't you need to assign them to a recipient with a role? This is where I'm getting stuck. In docusign, if a field isn't assigned to a recipient, it gets deleted. But I don't have a recipient for fields that I want to assign to columns in Smartsheet. This seems like a major error/oversight in the docusign integration.

    The original poster seems to have had the same question I had, but I'm not understanding your response, which the OP seems to have found helpful. I'm hoping this may also solve my similar problem, if you don't mind elaborating a bit more? Thank you for your help!

  • Lesa Weaver
    Lesa Weaver ✭✭✭

    Hi @vdemattei , When we created a template in DocuSign, we did find a difference in how it worked depending on if we imported a Fillable PDF Form (as the documentation stated) versus a regular PDF document (that has the format for our form without the fields identified.) We found that it works best for us to use the plain PDF. Here are a few things to help explain generally what we did (but it isn't every step).

    Prepare Template in DocuSign:

    1. we create the template name,
    2. add/import the plain PDF for the document format,
    3. at the "Add recipients" page we fill in one Role (this is the column name from Smartsheet - but do not add a name or email because those will actually come from a Smartsheet column and be different for each row of data we send when we generate the document),
    4. and create the custom email message.

    What we learned: If you only have one Role then all fields will, by default, get assigned to it so the option doesn't show in your field definitions in DocuSign. If you have more than one Role defined, we had to choose a signing order. Based on that, the DocuSign field definition showed an option where each field has to be assigned to one of the roles. We are working through some other issues right now concerning multiple roles so I will stop with this for now.

    You probably aren't having issues with the rest of the process but briefly:

    Add Fields - Template: We create each field with a unique name in the DocuSign template on the form we imported (usually to match our Smartsheet Columns for intuitive matching later). This allows us to use checkboxes, drop downs, required fields, etc. to create smarter forms. We add our DocuSign signature and save.

    From Smartsheet sheet:

    1. Right click on a Row and select Generate Document,
    2. choose the DocuSign template to use,
    3. we use a column in Smartsheet where we have a formula to create a unique file name based on row data so we put that column name in the "Output Name" field at the top. This makes sure that we have proper names on the document when it is attached and helps us know which row it goes to in our backups later.
    4. then we match the other column names to the form field names and drag and drop.
    5. Then save and generate.

    Special Note: You didn't ask but we have found when we tried to sync data from the DocuSign form to the Smartsheet columns, there are "unsupported Smartsheet features" in the interface that aren't documented and there are no error messages given. So to save you some headaches, when you mark in DocuSign the fields you want to data sync, Smartsheet columns:

    1. cannot have a formula
    2. cannot have "allow multiple values per cell" marked
    3. cannot have "restrict to list values only" marked
    4. cannot have "restrict to dates only" marked

    Hope this helps you.