Getting Data Shuttle to recognize a column as number/text, not checkbox

Options
amy_ilearning
amy_ilearning ✭✭
edited 10/18/23 in Add Ons and Integrations

I'm in a pickle. I set up a Data Shuttle that imports a CSV, but the target sheet recognizes 0s as a checkbox. I need it to recognize the 0 for the formula. When I try to change the column type (Actual Work in the screenshot) from Auto to Number, it won't give me that option.

Changing the column type in the source sheet changes the 0s to false, and it still won't let me edit the column type in Data Sheet.

So then I changed the target sheet to an .xls (the only other download option from NetSuite, the source), but Data Shuttle won't allow me to select it when editing the Workflow, so I'm guessing .xls isn't supported.

What do I do? How do I get a Smartsheet Sheet to recognize a field with several 0s as a text/number instead of a checkbox?


Tags:

Answers

  • Tim C
    Tim C ✭✭✭✭✭
    Options

    To clarify, is the goal to have a checkbox type column in Smartsheet or a Text/number column? If it's a checkbox column in SMAR only true/false answers in your imported excel file will transfer correctly. If you have a text/number column and 0s turn that cell into a checkbox, that's odd behavior. Could you take a acreenshot of the raw data you're trying to import?

  • amy_ilearning
    Options

    I think it's odd, too. The data comes from NetSuite via a CSV emailed to Box, then uploaded to Smartsheet. The raw data column is text/number, and all cells in those columns are numbers. The only columns that are changed to checkboxes are ones that have 0s in cells, and they're changed to unchecked in Smartsheet. When I change the column in the Smartsheet sheet to number/text, it changes the 0s to "false"

    Like I said in my original question, workflow mapping won't let me change the column type for these. It's stuck on Auto, I cannot select Number or Text


  • Danielle Wilson
    Options

    @amy_ilearning Hi Amy! I think to @Tim C 's point you'll need to change the column type on the sheet within the column settings within your sheet. Once you've saved that on your sheet it might take a little while for Data Shuttle to catch up to that change you've made but then you should be able to adjust the mapping (or honestly Auto should be fine once you change it from being a Checkbox column type to instead be Text/Number).

    Danielle W.

    Product Marketing

    Smartsheet