Data Shuttle not pulling in new rows from source sheet


I have a Data Shuttle workflow that I set up that has been working for 4 months, but for the past few weeks, has not been picking up rows that should be added to the Target sheet. Any ideas why it suddenly stopped working?

The source file is saved in Box (I've verified/reconnected by Box account). There are 96 rows in my target sheet currently, but should be 99 based on the source sheet.

I've selected to merge data and add rows (we often make updates after the rows are added, so don't want to use the Update option)

No filters set:

Columns are all mapped. I refreshed just in case we had renamed a column recently and also forced the column type in most instances. The Row IDs are unique, I double checked in our Target sheet that the missing rows are not included anywhere.

The workflow is scheduled to run every hour, and each hour it does run, but does not update anything

Here are the workflow results:

The first three rows in the screenshot below are the ones missing, the 4th one worked when the row was added to the source sheet:

Any ideas on what I could adjust to make this work?


  • Tim C
    Tim C ✭✭✭✭✭

    First, thank you for being so thorough in your post with screenshots. This is odd bevior so we can try some non conventional solutions. First I would try duplicating your data shuttle workflow and point it to a new sheet to see if those rows are still missing. I would also go into Box and see if the file ID has changed since Data Shuttle looks at the ID, not the file name. You could also temp. Stop your shcedule Nd just force run the workflow to see if anything changes. One other oddity- if people are in your source file in box as Data Shuttle is trying to run, ive seen intermittent success with the workflow. If none of those work, im sure another community member has an idea, but id open a support ticket and if you have pro desk, maybe schedule a session?.

  • krsch88
    krsch88 ✭✭✭

    Thanks, Tim! I rebuilt the workflow to a copied sheet, and that worked, so I rebuilt the workflow to go to the original target sheet, and that worked! So something must have been wonky with the original, but I have things working again :) Yay for no longer needing to manually copy/paste!