I can't authenticate to Zapier, generate a working API token nor create a support ticket

Options

I am a paying Business tier customer. Here are all the problems I encountered so far:

  1. When trying to authenticate to SmartSheet from Zapier. When I try, I get an error saying the user has not been found or I am trying in the wrong region error. I did some research, this might have to do with Zapier integrations apparently not working with EU tenant users.
  2. I tried to do my automating through API then. But despite generating multiple API tokens, I am getting a 1002 error stating "Your Access Token is invalid" on any call I try.
  3. So I gave up and tried to raise a support ticket. But despite being a paying customer, when I try to log into the support portal, I am being redirected to a website troubleshooting support portal access issues.

Not sure what to do next. I would appreciate some help.

Answers

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi @lov3.digital

    1 - Yes, Zapier does not currently integrate with the EU instance of Smartsheet.

    2 - If you're on the EU instance, is it possible that your API calls have not been updated to state EU in the URL?

    The default examples in the API documentation are the .com instances, so your access token would not be valid unless it's connecting with the EU instance.

    The base URL for each API call is smartsheet.eu instead of smartsheet.com. This documentation uses smartsheet.com in all examples.

    Here's the documentation on how to connect to EU using the API: https://smartsheet.redoc.ly/#section/Smartsheet-Regions-Europe

    3 - If you are incorrectly redirected to the Troubleshooting Portal Access Help Article, you can submit a Support Ticket from that page through the Contact Support form link (under bullet point number 2 in the article). Please let Support know what URL you're getting with the Help Article redirect and they'll be able to look into this for you.

    Thanks!
    Genevieve