RTF in Dashboard Widget

edited 12/09/19 in Using Smartsheet
01/30/19 Edited 12/09/19

I downloaded an example dashboard which tracked multiple projects.  Looked good and decided to build my dashboard to match example.  Example dashboard has a Rich Text Widget which has multiple formats within.  However when I try to use the rich text widget it does not allow me to have varied formats (different text sizes, bold or underline).  It defaults to making all text the same format.  How was this done on the example I downloaded?  How can I achieve the varied formatting in my dashboard?

Comments

  • Mike WildayMike Wilday ✭✭✭✭✭

    There is an icon in the Report Widget that disables formatting. See attached Screenshot.

    2019-01-30_11-20-35.jpg

  • The original post was regarding formatting in the Rich Text Widget, not the Report Widget. The Rich Text Widget does not have a button to enable/disable formatting.

    The formatting available, and the assumed formatting that is not user accessible in this widget, is sub-optimal. For instance, I'm unable to create a text widget that contains multiple independent lines of entry and force them to be single spaced.

    Example - I want the rich text widget contents to look like this, so that I can include a list of core team members at the top of a project dashboard.

    name 1               - Program Manager 

    name 2               - Business Development 

    name 3               - Production

    name 4               - Product Development 

    name 5               - Product Marketing Manager 

    Instead I get this something like this - only it isn't a blank line in between each entry. The Enter key during text entry causes something other than a single line feed - not sure if it is 1.5 or what. But it isn't what I want to display.

    name 1               - Program Manager 

    name 2               - Business Development

    name 3               - Production

    name 4               - Product Development

    name 5               - Product Marketing Manager 

     

    Any suggested work-arounds? I already submitted an enhancement request, but would welcome any ideas in the mean time.

  • And I see that my post picked up the same formatting glitch that I am struggling with. The example of what I want it to look like does NOT contain that much space between each line (and did not look like that when typing in my post). Sigh...

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Hi,

    Not sure I follow!

    Is the attached how you'd like it to look?

    Have a fantastic week!

    Best,

    Andrée Starå

    Workflow Consultant @ Get Done Consulting

    Screenshot of Google Chrome (2019-05-30, 13-38-18).png

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • pjhpjh
    edited 05/30/19

    Yes. Problem is, it doesn't look like that in the widget. Text is not lined up properly and if I hit the "return" key for a new line it adds more than single space. I am not seeing a way to change the spacing to single line spacing instead of whatever it turns out to be.

    The work around I've found is to paste from something line Notepad back into the widget. But, if I later need to edit it I have to do the edits somewhere other than the widget and paste again. For example, in the snippet you show, if you add an entry between names 3 and 4 there is extra space that cannot be edited out in the widget. See screen shot. Also notice that the "-" is not aligned from one line to the next and tabs are not supported to accomplish this.

    screenshot.JPG

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    That is how it looks for me in the widget.

    The only thing that doesn't work is the tab key.

    There are a few workarounds.

    • You could use the Metric Widget instead and link from a text field on a sheet.
    • In the Rich Text Widget use shift+return to get the next row directly underneath.

    Would any of those options work/help?

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Thanks. The shift+return will produce the desired result. Thanks!

  • Andrée StaråAndrée Starå ✭✭✭✭✭

    Excellent!

    Happy to help!

    Best,

    Andrée

    SMARTSHEET PARTNER & CONSULTANT / EXPERT

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Roland HorwoodRoland Horwood ✭✭✭✭✭

    Hi,

    Nope, shift return doesn't work...

    Including in this text box!

    I can't get single line spacing, seems pretty basic and it used to work.

    If I edit some old dashboards then the spacing goes to pot and there's no undo... Arghhh

    Ro

  • Hi Roland - you're right. The ability to use shift+return to get single line spacing seems to have been broken (it used to work). And I agree - it is a really basic and fundamental formatting function.

    More maddening is that widgets that used to be formatted correctly are now messed up, which translates into dashboards that were good now look terrible.

    Come on Smartsheet - please address this one!!!

  • Any luck on finding a work around for this? Formatting is still randomish spacing, with no way to get single spacing in a widget.

  • Roland HorwoodRoland Horwood ✭✭✭✭✭

    Still broken....

Sign In or Register to comment.