Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Insert row does not auto-fill

2»

Comments

  • A have a twist on this problem:

    I have created a Zap (Zapier) to add  a row at the bottom of my sheet when a new appointment appears in my Google calendar. The row gets created, but I also have 3 extra cells with formulas to identify some of the new appointments buzzwords. The cells with the formula do not get duplicated in the new row.

    However, if I cut that row and paste it in the very same row, the formula cells get populated.

    I understand that there is a 3rd party product involved, but it seems to be in line with what is discussed above. 

  • philippejj0421
    edited 05/14/18

    Well... I stand corrected: This morning is another day and I am finding out that the auto-fill did work after all.

    Overnight, Zapier imported a couple of rows and the new rows did get the formatting from the rows above.

    I am monitoring the situation...

     

  • Hi @philippejj0421,

    i have the same issue and i can clearly say, it is working in its own way. One day is perfect, the other too and then something is not going as it should go and cells are not filled up with formulas. What's more interesting, it's not like all of them are not copied as some of the colums are 100% ok. Just one column behaves in such strange way.

    It could be acceptable for projects that does not need to count something in very changing environment, but I have a team who is responsible for some stock and one sheet is used to report moves of stock in and out, and the other sheet has to sum stock to show live level. It is not possible if some of cells are not working as they should.

     

  • Thank you Marcin.

    It looks more and more like a bug.

    I am not sure if this discussion is monitored or if we should submit an official enhancement request. (even though it is not a real enhancement, more like a fix)

    Anyone from SmartSheet engineering reading this?

    Or can the moderator forward this to engineering?

     

  • I have exactly the same problem. When inserting a new row, all formulas are copied, but when I insert a new row for the second time (right under the first newly inserted row) only one formula gets copied. Does anyone have a solution for this?

     

  • It's a couple years after this thread and I am experiencing the same bug. The auto-fill is not working for newly inserted rows. Any update on this from Smartsheet?

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi,

    Where are you adding the new rows and is it in the same hierarchy level? (Children, Parent)

    Hope that helps!

    Have a fantastic weekend!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • I have 6 rows at the same level each having the same formula. I inserted a row in the middle so there are 3 rows above and 3 rows below all using the formula. The new row doesn't have the formula.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭
    edited 09/06/19

    Have you tried adding some text to the primary column as well?

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • bhphilly
    edited 09/06/19

    I added text in the primary column each time I insert a new row. In fact, I am using the formula below to verify that the primary column is not blank. "Task" is the name of my primary column. "clone" is the name of the column that should be autofilled with the formula.

    =IF(NOT(ISBLANK(Task3)), VLOOKUP(clone1, clone1, 1, false))

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Ok.

    I'd be happy to take a look and see if I can find the reason for it not working.

    Can you maybe share the sheet(s), copies of the sheet(s) or some screenshots? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Any updates on this issue?  We're having the same problem.  We insert a row, the formula is consistently in more than 2 rows above, yet the formulas are missing in the new row.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi,

    Have you made sure that the rows are on the same level/hierarchy?

    Hope that helps!

    Have a fantastic weekend!

    Best,

    Andrée Starå

    Workflow Consultant / CEO @ WORK BOLD

    work-bold

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

  • Yes, they are at the same hierarchy, nothing is indented.  I can't consistently duplicate the issue.  It doesn't always happen when a row is added, and I've checked the formulas around the new row.  And, of course, it usually happens when someone else adds a new row, so it may be something they are doing that's weird, but when I ask, they just say they inserted a row or copied another one.

  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Strange!

    Have you searched the Activity Log for any clues?

    If you haven’t already, I would recommend that you reach out to the Smartsheet Support Team. Smartsheet Support Team

    SMARTSHEET EXPERT CONSULTANT & PARTNER

    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: www.workbold.com | E: [email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me about help with Smartsheet, integrations, general workflow advice, or something else entirely.

This discussion has been closed.