% complete not rolling up

Options
SN
SN
edited 12/09/19 in Smartsheet Basics

Friends,

I am having a hard time with the % complete.

All I want is a simple % complete - regardless of the duration.  My parent / child rows are correctly intended. 

I have 3 tasks -

Task 1 - 75% complete

Task 2 - 25% complete

Task 3 - 50% complete

Parent % complete should be 50%.  How do I achieve this?

Thanks.

Comments

  • Shaine Greenwood
    Shaine Greenwood Employee
    edited 04/17/19
    Options

    Hello—

    As you've found, when you use the % complete rollup functionality with dependencies, you'll see a weighted percent complete based on the duration and % complete of all child tasks.

    If you'd rather have % complete rollup that doesn't take duration into account, then you'll need to disable the dependencies functionality altogether and manually create a formula in the parent rows of your sheet.

    From your example, it appears that you're looking for an average % complete as opposed to a weighted roll-up of total % complete. Try the following (I'd recommend making a copy of your sheet and testing this out on the copy first):

    1. Disable dependencies, more info on this here: https://help.smartsheet.com/articles/765727-enabling-dependencies-using-predecessors
    2. You'll want to then place a formula like this in your parent rows:



      =AVG(CHILDREN())
  • SN
    SN
    Options