Has anyone figured out how to set a default size to pdf text for the Document Generator?


We are hoping to utilize the Generate Documents feature for both internal and client facing processes but cannot seem to figure out how to stop the data that maps into the forms from auto-sizing itself. This is making the client facing forms look horrible. None of the existing size formatting in my pdf carries over, and we don't want to have to edit each individual pdf after it generates - kinda defeats the purpose of the auto-generation.


  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @CHoffman_FCB14

    Currently if your Smartsheet cell contains more text than can fit in your PDF field at the size you have it set to, Document Builder will automatically adjust your text size so that it can all fit properly.

    There isn't a way to force it to stay to a specific size format no matter the length of text. Please let the Product team know of your use-case and request by filling in this form, here.



  • Mark Candela

    We had a similar issue with the AutoSizing that we solved by looking at the options for each field in the actual PDF form builder and changed the options of the field to lock at a particular text size. You can either set the default size or change field by field in your program. For long text fields you can opt for scrolling or have multi-lines.

  • CHoffman_FCB14

    Yeah, I am able to set defaults within my pdf program, and had my document already formatted the way we wanted it with multi-line text, etc. None of those settings seem to be preserved upon importing as a doc builder template. So once Smartsheet generates the form and populates the data, I would have to modify the fields on each individual pdf so we lose the efficiency of doc builder.

  • Michael DiFabio

    We are also faced with this issue. Please let me know if you (@CHoffman_FCB14) found a solution. As we would really like to have the font consistent in our reports.

  • DanielW
    DanielW ✭✭✭

    I'd also be interested in this feature. Currently debugging by changing the text field box size but this is incredibly time consuming

  • elizabeth.h

    Chiming in with another voice in favor of this feature. It's very unprofessional looking for the document to format fonts this differently- showing an example here where there are only a few characters of difference and the text fields are the exact same size in Adobe.

    Not great for anything client facing. I don't understand why there isn't an option to choose a default font size- say 16, and nothing would go above that size, but if the text doesn't fit it could go below that size. That seems like the most logical implementation of font size control.

  • Sheila J
    Sheila J ✭✭✭

    I have issues with the document generator reading text instead of numbers. I've formatted the fillable PDF to return a barcode font. The smartsheet has numbers in the column and it is printing the barcode as letters instead of numbers. Any ideas?

  • Ellie Ruby
    Ellie Ruby ✭✭✭

    Hi all -

    The font size and font type are dictated by the PDF. When you are in the "Prepare Form" area within the PDF, right click the inserted text field to bring up "Text Field Properties". Within this help box, click on the "Appearance" tab and update the bottom "Text" section. I have noticed if the Font Size property is set to "Auto" it brings in different font sizes based on what the column type is within Smartsheet so I have set a standard font size for all my forms.

    Hope this helps! 😀

  • Laura K
    Laura K ✭✭

    We are also experiencing this issue. Font sizes are changing wildly from the settings we put in the Text Field Properties window in Adobe Acrobat.