Data Shuttle Not Working: Please select a Source in order to see dropdown options

I keep getting "Please select a Source in order to see dropdown options" when attempting to setup a Data Shuttle workflow. See screenshots below. This is keeping me from being able to transfer updated data from "Local copy" spreadsheet to "Actions" spreadsheet. Both sheets are within the same workspace and have the same column fields. Please help as we are attempting to use data shuttle in order to have our Smartsheet dashboards updated regularly with up to date data.

No Filters applied


«1

Answers

  • DesireeJones
    DesireeJones ✭✭✭✭✭

    I am having a similar problem and my report uploads are not working. I am trying to figure out a solution and I will comment again if I succeed.

  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    You need to enter the attachment name there in your first screenshot. You are telling it where to look, but you aren't telling it what to look for.

  • sndctrl
    sndctrl ✭✭

    @Paul Newcome I tried what you suggested, but this did not help at all. I even attempted to add the file extension. It did not work.


  • Paul Newcome
    Paul Newcome ✭✭✭✭✭✭

    Make sure the file is already attached to the sheet and that you are selecting the correct sheet.


    I just tested it to make sure, and you do need the file extension.


  • l.gann
    l.gann ✭✭
    edited 12/14/22

    @Paul Newcome I'm having this same issue, but I've got a source file selected. Can you please advise?

    My file size is under the 1000MB limit and the document is a supported file type.


  • Meg Y
    Meg Y ✭✭✭✭✭

    I am having the same issue.

    Data Shuttle set up

    1. Smartsheet Attachment
    2. File is attached to source sheet
    3. Naming convention is correct
    4. Workflow action is replace all
    5. Columns in both Excel file and Smartsheet location match up
    6. Get same error "Please select source in order to see drop down options"
  • Hello,

    I allow myself to revive this discussion because I am currently having the same problem. I will fetch a document from my google drive to increment them in Smartsheet. But I encounter this error message 'Please select a source in order to see the drop-down options' which prevents me from finalizing my workflow. (sorry for my English...)

    Cordially,

    azerty64

  • no it is full. But to create a workflow, does the file have to be in our drive or also in the shared drive?

  • V_Szombathy
    V_Szombathy ✭✭✭
    edited 05/02/23

    So weird, I was having a similar issue with a Google Sheet file that I already had linked up to Data Shuttle to feed an existing Data Table. I was trying to link up a new data table to the same file (this would be the third time I've done this activity on the same file), but was getting this "Please select a Source in order to see dropdown options" error message. This had never happened before, and everything looked the same in the setup as the others.

    I ended up removing the protection on the sheet and then the issue resolved. So odd because I have protection on the other sheets as well, but maybe I set up the protection after creating the data shuttle in those instances? Anyway, just wanted to throw that out as a possible fix for any of you who may happen to have protection on a sheet (or maybe even cells - not sure about that one cause my protection was at the sheet level).

  • V_Szombathy
    V_Szombathy ✭✭✭

    Actually, strike that... it worked when I removed the protection on a separate test file, but not on the main file that I need to really use as the source. Back to the drawing board... I think I'll open a case as there doesn't seem to be too much on this issue out in Community. If I figure anything out with support I'll circle back here to update.

  • V_Szombathy
    V_Szombathy ✭✭✭

    I wish I had a clear solution to post here for everyone, but all I can say is that I got tied up in other things during the day and still hadn't sent in the case so I thought I would try one more time at the end of the day before submitting the case. Yep, you guessed it... it worked. I'm not sure what happened. I had not changed anything since the last time I tried. The only thing that changed was that some time had passed. Perhaps that is the issue? Maybe SS needs some time to recognize changes to the Google Sheets file? I'm just not sure. I do still think perhaps sheet protection had something to do with it because the other day when I tried multiple times it never worked and then I tried today in the morning and no dice... so, maybe it needed some time to process the changes I made to remove the protection (the sheet does have multiple query and arrayformulas so maybe that causes a delay?). I really don't know though... very odd. Nonetheless, the mapping worked and the DataTable was populated with data through DataShuttle. Sorry for the cryptic answer, but that's what happened. ;)

  • amhba
    amhba ✭✭

    I am having the same problem when trying to create a new DataShuttle workflow using a very simple Excel spreadsheet stored as a Smartsheet attachment. It is a 3800 row sheet with about 20 columns and no formulas, and no data longer than 100 characters per cell. I tried creating a new sheet from that file by uploading it directly into Smartsheet, then creating an offload workflow, then uploading.

    I was able to run a normal upload/offload/upload workflow earlier today (purely in DataShuttle based on a Smartsheet attachment) with no issues for another sheet. Hopefully this isn't permanently broken and it is just a mysterious issue with that particular spreadsheet.

    Using this extremely frustrating workaround, the offload alone took more than 4.5 minutes to run. In comparison, workflows with similar size data sets typically take about 10 seconds to run, so I think that there is something intermittently breaking in the background with DataShuttle. But Smartsheet did recognize the file generated via offload.

    The upload (using just a simple "replace") took more than 2 minutes to run (instead of the expected 20-30 seconds), so I think something may be broken with Datashuttle.

    I hope this gets resolved soon and that the 20 other upload (from Smartsheet attachment) to upload (replace data) or offload (update dropdowns) workflows I use weekly do not break....

  • amhba
    amhba ✭✭

    Resolved: The sheet I was trying to use had a hidden (really extremely small) row 1, so row 1 was blank and there was nothing to map. I deleted that row and now it seems to work.