Is anyone else still having "random and intermittent" issues with cell links not working?

We have been having issues with cell links not updating since early October. Smartsheet support and pro-desk say they are working on it and then close our support tickets. Does anyone have any more information on this? We still have issues, but no one is talking to us.


  • Mike TV
    Mike TV ✭✭✭✭✭✭

    @Lacey England

    Yes. Just last week I was using a sheet and entering a lot of data to it via a dynamic view I had set up the sheet with. As I was entering data one of the formulas which uses cell references to an outside sheet kept saying #INVALID REF. I would open the sheet it was referenced to and refresh it which would fix the links but then 5mins later #INVALID REF again. I even set up new renamed cell links and re-did the formula but that didn't stop the errors.

    The errors persisted all day as I worked on entering information to the sheet. It's stable now but it wasn't on that day.

  • AVGme
    AVGme ✭✭

    We're having the same issues! When inserting images into a sheet, the cell links to another sheet are either blank or show the image name. We have to change the link to another cell and then back to the image and it works. Smartsheet closed my ticket back on 10/22/22 for this issue stating it was resolved.

  • Mike TV
    Mike TV ✭✭✭✭✭✭


    I was entering both text and was also inserting images into the sheet that was giving me problems.

  • @AVGme We have many sheets impacted. It is still not fixed, but they say that are working on it. Not much communication about this from Smartsheet although it is clearly still an issue.

  • AVGme
    AVGme ✭✭

    @Mike TV @Lacey England

    It's also impacting our text only cell links and multiple sheets. I just opened a new ticket with support. Hopefully they get this resolved quickly because it's becoming quite cumbersome to manually fix every link.

  • @AGVme Do your text links stay fixed once you manually update them? We have have manually fixed some of ours and sometimes they update after that, and sometimes they don't.

  • AVGme
    AVGme ✭✭

    @Lacey England Sorry for the delay! I don't think we've come across any that don't update after we manually "fix" them; they always seem to update correctly with the manual change.

    Smartsheet support fixed two sheets of ours on their backend and said that it was an intermittent issue. We created a project from a template using Control Center yesterday, and it was all wacky. Submitted another ticket in hopes they can find the glitch.

  • This must explain why almost all the projects my team provisioned while I was OOO aren't linked correctly. I've been searching through change logs and double-checking links for the last two days in an attempt to figure out what happened with the toolkits, control center, each project, etc. All the projects that were created on November 14th have the same cell link issue(s), but the projects provisioned last week seem to be fine.

  • @Pixel Sounds like a similar issue to what we had. Support finally fixed it on the back end for us. Not sure what they did, but I would provide url links to the metadata sheets, sheets where you have the link issues and the template sheets you are using in your blueprint in the service request.

  • Same issue here - support slow to respond and I have a Prodesk set up for next week to explore.

    But .... I did a test. Set up a single input Smartsheet (no formula, just a number) and a single linked cell destination Smartsheet. Also set up a corresponding report and dashboard. At 600 mbps network speed, report and dashboard update immediately, link takes about 4 minutes.

    I'm building this for client so this is starting to make me look stupid, so pretty frustrated.

    If I get resolution thru ProDesk, I'll share. If anyone else finds a solution, please share


  • PMOGal
    PMOGal ✭✭

    Cell linking was working fine. And now, I can no longer create linked cells in a sheet where I could previously create links. "Link from Cell in Other Sheet" is grayed out.