How do I fix Jira Connector "Private Key does not match value in JIRA" error

Options

This morning we started receiving the following error on all of our Jira connector workflows.

"Your workflow has been disabled due to the following error: Private Key does not match value in JIRA. Please verify that the Private Key in your JIRA Application Link matches the value in your Smartsheet for JIRA Host listing. To correct this issue, please log into Smartsheet for JIRA and edit the workflow to re-enable it."

I tried editing a workflow and also creating a new one, but still get the same error. I checked the Application Link configurations in both SmartSheet and Jira. The Consumer Key and the Public key match in both SmartSheet and Jira. As far as I can see we have not changed anything that would have caused this.

What can I do to correct this?

Answers

  • Connor Rashotte
    Options

    We have also experience this for all our connectors this morning

  • Matt Baker
    Options

    I opened a support ticket. They just responded a few minutes ago. With the following response.

    "Our engineering team is currently investigating this issue, we've attached your case to the ongoing investigation and will provide updates on it as soon as possible. Thanks for your patience in the meantime!"

    Looks like the problem is being addressed.

  • mgerster
    Options

    Yes, same issue being seeing at my org.

    Smartsheet shows connected, yet all connections are down with the same "Private Key does not match...." error.

    Some more color - Attempting to just go around this also doesnt work. If i try to Configure Application URL in JIRA again from scratch and point to https://app.smartsheet.com i end up with the following response in JIRA: "No response was received from the URL you entered - it may not be valid. Please fix the URL below, if needed, and click Continue."

    Good to know they are looking into it.

  • Marlana K.
    Marlana K. ✭✭✭✭✭✭
    Options

    Experiencing the same here as well

    MARLANA KALINOWSKI

    Sr. Business Analysts / Smartsheet Solutions

    National Pharmacy Services | Genoa Healthcare

  • Allen T
    Allen T ✭✭
    Options

    I am also having the same issue, I just submit a ticket to see what is going on,. Another thing that is weird is that if you try to connect them, it tells you that you don't have access to this

  • Genevieve P.
    Genevieve P. Employee Admin
    Options

    Hi all,

    Thank you for contacting Support and reporting what you experienced; this has been resolved as of December 16th. You can view the details and status of this incident from the Smartsheet Status page, here:

    Resolution:

    A fix has been implemented that will require customers with disabled workflows to manually re-enable JIRA connector workflows in the UI. At this time, our service is functioning as expected and we are closing this incident

    Cheers,

    Genevieve