Data Shuttle Import Timestamp issue


I am attempting to import data from Excel with several Date & Timestamp fields.

The format in the source file is: 04/16/2024 21:17

What I get in Smart Sheet upon Import: 45371.83695601851851851851851851852

I have tried leaving the destination column as text/number, I have tried setting it to Date - no dice.

The default settings for the timestamp formatting in the excel file is (this is how the system that generates the file sets it):

I found that if I manually change the format to Date on these columns in the excel file before import, it works. This is a pain as I am trying to fully automate this process. Is there a way around this?

I see other timestamp questions on here, but cannot find guidance on this particular issue.

Any ideas?




  • Leah Rankin
    Leah Rankin ✭✭✭

    Do you want the date or the timestamp or both? If you're saying it works if you change it to date, I'm guessing you want the date? Unfortunately, like you've found, I do not believe there to be a way to do this on the Smartsheet end, it will need to be changed in the Excel file. Depending on what your full process pre-Smartsheet upload looks like, maybe an Excel macro or something similar could be of assistance.