Welcome to the Smartsheet Forum Archives


The posts in this forum are no longer monitored for accuracy and their content may no longer be current. If there's a discussion here that interests you and you'd like to find (or create) a more current version, please Visit the Current Forums.

Make Collapse ALL default

edited 12/09/19 in Archived 2016 Posts
09/29/16 Edited 12/09/19

I have clients with indented children. Everytime I come to the sheet the children are fully expanded. How do I make Collapse ALL the default setting? Matters not if I save it as collapsed.

Previous1

Comments

  • Richard Rymill SBPRichard Rymill SBP ✭✭✭✭✭

    Hi Joe

    something strange happening at your end then, because when I open a sheet it opens where the hierarchy was last open, ie Fully opn or partial or closed? 

     

    Is someone else opening up your hierarchy?

     

    Hope that helps? 

    Richardr

  • Where would you set heirarchy other that with collapse?

  • What's interesting is this behavior just started. It seems its coincident with using the new Filters tool. 

     

    If I collapse the sheet then move to another sheet, then back to the collapsed sheet....it's no longer collapsed, even if I save before leaving.

  • Yes, it seems to have started with release of the new Filtering functions.

    I'm having the same issue ; In my case, after removing a filter, all rows are expanded. This is most undesirable. Is there a keystroke or hotkey to collapse all ?

  • The collapsed/expanded view is shared between all users on the sheet. if your client expands the rows and saves that is the view you will see when you open the sheet.

     

    Using Find (cntrl+F) and/or applying filters will expand rows as well but will not always be as apparent.

  • You have to click the column header for the dropdown then select collapse all. Don't want to do this each time I access the sheet

  • Thanks much Joe - works great..

    An option for setting a default would be simpler ...

  • @Joe The default behavior is that the hierarchical expand/collapse reflects the most recent save made to the sheet—whether that's your save or another collaborator's save.

     

    If this appears to only happen on one sheet for you, ask all of your collaborators to close the sheet temporarily on their end. Then make hierarchy changes and save. Close the sheet then navigate back to the sheet and see what it looks like.

     

    Your sheet should reflect the way you set the hierarchy after you've saved, if it still doesn't and you've confirmed no other collaborators are looking at the sheet (and possibly overridding your saves), then email [email protected] so our team can troubleshoot further.

  • Thanks....I will try this.

     

    The issue is we use the parent / child feature a lot....and I'm sure with autosave the expanded list gets inadvertantly saved due to autosave. 

  • Hi, I had the same problem and narrowed down the issue:

    - If there is no filter selected, collapsing is kept when we come back to the sheet

    - but if there is a filter activated, then all lines are uncollapsed when we come back to the sheet

    --- I tried to save the sheet manually after collapsing to make sure this was not a side effect of auto-save

    --- and I'm the only one using the sheet so this can't be due to other users

     

    This clearly looks like a bug, which makes the collapsing feature useless as soon as we have a filter. If confirmed, any chance that could this be corrected?

     

    Thank you,

  • edited 02/07/17

    It is an acknowledged bug that's taking a long time to get corrected. The new filter option is great, but this makes it very unfriendly when using indented child records.

  • OK thanks for the feeddback/confirmation.

    Do you have any visibility about when it will be corrected? (So we now if we should reorganise sheets or if we can wait)

     

    Thanks you,

    Xavier

  • Nope....I was told months ago that it's in the works.

  • Susan AlexanderSusan Alexander ✭✭✭✭✭

    Any word on this? My issue is the same as Xavier LN. I'm using a filter (only show tasks that are not completed) and every time I leave a sheet and return to it, it's completely expanded, even if I saved it before leaving. Very annoying, since I move between sheets continually.

    Thank you!

  • L ThrasherL Thrasher ✭✭✭✭

    I agree.  I'd like to have my sheet default to 'collapsed' after I filter.

This discussion has been closed.