Any ideas on why the pivot app does not update with new data in the source?

Randy Saad
Randy Saad ✭✭✭
edited 06/14/22 in Add Ons and Integrations

I have a pivot sheet set up to pull data in from a report. The initial set up worked perfectly and when I run the configuration manually, the data is pulled in. But when the runs hourly (Update Frequency is set to 1 hour), no updates are made. All config logs show "Success!" but new data is only added to the pivot sheet if I manually run the pivot workflow.

What am I missing?


  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Randy Saad

    This doesn't sound like expected behaviour; if it runs properly when you run it manually then the set-up is correct and it should run successfully every hour as well.

    I would suggest reaching out to Smartsheet Support with screen captures of your workflow set up, the config logs showing no updates happened but it says "success", screen captures of the source Report and destination sheet (and URLs), along with any other relevant information. They'll be able to work with you in a private channel to determine the root cause.



  • Hi Randy, Genevieve,

    Did you ever found out what was the issue here. I'm also facing similar thing, where logs show "Success!" but new data is not updated on target sheet.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @Aditya Bapat

    I checked in with the Support team and they confirmed other customers reported something similar; they've investigated what was happening and this should now be resolved! If you're still seeing unexpected Pivot behaviour, please do reach out to Support using the link above.



  • Thank you Genevieve for your comment. I had logged a ticket with Smartsheet support for this issue and they reached out to me yesterday confirming the fix has been implemented. I checked and it seems the pivots are working fine now.