workflow automation - rows aren't moving?


I created a workflow to move rows once a column status is changed to "complete" within any row.

But the workflow didn't trigger, even when I manually changed the status to something else and back again, saved, refreshed, tried again. It finally worked when I moved the row to a different spot in the sheet (shifted up one to trigger the "add/change row") and then the row disappeared from my primary sheet.

I don't think I should need to actually move the row to trigger the workflow, and also, the row never appeared in the secondary sheet, so now my data is missing.

Both sheets are saved in the same workspace, and they have the exact same formatting (the second is a blank copy of the first).

What went wrong, and how do I fix it?

Thank you!


  • Andrée Starå
    Andrée Starå ✭✭✭✭✭✭

    Hi @enewgard

    I hope you're well and safe!


    Can you describe your process in more detail and maybe share the sheet(s)/copies of the sheet(s) or some screenshots of the sheet? (Delete/replace any confidential/sensitive information before sharing) That would make it easier to help. (share too, [email protected])

    I hope that helps!

    Be safe and have a fantastic week!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    Did my post(s) help or answer your question or solve your problem? Please support the Community by marking it Insightful/Vote Up or/and as the accepted answer. It will make it easier for others to find a solution or help to answer!


    Andrée Starå | Workflow Consultant / CEO @ WORK BOLD

    W: | E:[email protected] | P: +46 (0) - 72 - 510 99 35

    Feel free to contact me for help with Smartsheet, integrations, general workflow advice, or anything else.