Automation not displaying sheet I'd like to move rows to

USAMDC_8501
edited 08/01/22 in Smartsheet Basics

I've had this issue before and still continue to have this issue where a sheet that I create (for archive purposes) is not displaying in the automations for me to move rows to. I created this sheet last Friday and it's Monday now, and the sheet is not displaying. Does anyone know why this is? This isn't the first time this has happened either. Please advise.

Answers

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @USAMDC_8501

    This is likely to do with who is the owner of the current sheet, where you're taking the rows from.

    If you are only an Admin on this current sheet, you'll need to share the Owner to your destination sheet as well. Once the current owner has access to the destination sheet, this should now appear as a sheet you can select in the workflow! Essentially you can't "steal" rows away from the owner without them seeing the destination, does that make sense?

    See the Note at the top of this Help Article for more information: Automatically move or copy rows between sheets

    Cheers!

    Genevieve

  • Genevieve,

    I'm actually the owner of both sheets I'm trying to 'move rows' to, but ironically, I can see sheets that I'm not an owner of and transfer them there, which is why this issue is so confusing.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @USAMDC_8501

    Are you also the owner of the sheet where you're moving rows from?

    The automation will show you all the sheets where you and the current owner are both shared, including sheets where you have lower permissions. However it won't show anything where the current owner is not shared, even if you own those other sheets.

  • BRB
    BRB ✭✭
    edited 07/14/23

    Hi Genevie, I am running into a smiliar issue, but am new to Smartsheets and am looking for some detail instructions. Like USAMDC (above), I would like to setup automation for copying rows into another sheet. In my case I created and own both sheets, however when I go to create the automation...None of the sheets that I own appear as options...

    In your comment above "However it won't show anything where the current owner is not shared" I was trying to understand what this meant and how to fix

    What am I missing? Any help would be greatly appreciated :)

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @BRB

    How soon after creating the sheet are you searching for it within the workflow? It can take around 5 - 10 minutes for a newly created sheet to appear as an option.

    If this is the first time you're loading the sheet picker and its been a while since you last logged in to Smartsheet, the results may take up to 24 hours to index and populate the very first time.

  • BRB
    BRB ✭✭

    This is the first time I have created a sheet and logged into Smartsheet. I've been trying to find my sheet, but it sounds like it might not be available until 24 hrs.

  • Genevieve P.
    Genevieve P. Employee Admin

    @BRB

    That's very exciting! Welcome to Smartsheet 🙂

    Yes, try again in about 20 minutes. If the sheet still isn't showing when you copy/paste the full sheet name, try again tomorrow.

    As long as you're the owner of both sheets it should show up.

    Cheers,

    Genevieve

  • BRB
    BRB ✭✭
    edited 07/14/23

    As an update, I have pasted the image below for what I was seeing....However, when I copied and pasted the file name and hit Enter...it appeared and it worked! Thank you.


  • K095438
    K095438 ✭✭

    I am encountering the same issue as USAMDC_8501.

    I am the owner of both the source/original sheet and archive sheet. Please advise.

  • Genevieve P.
    Genevieve P. Employee Admin

    Hi @K095438

    Can you post a screen capture showing the word you've searched, and another one showing the sheet name? (But please block out sensitive data!)

    Cheers,

    Genevieve